Inconsistent Tidal connection

I know this has been discussed but I have only been able to log into Tidal from Roon a couple of times. I only get “There was an unexpected error, please check your account details”. I can log in from all my other devices using the same credentials. Doubly frustrating as I have accessed Tidal within Roon so I know it’s possible. During initial setup and file transfer, the SonicTransporter has been rebooted several times. It’s after these reboots that I can no longer access Tidal.

I am using SonicTransporter AP with Sonore MicroRendu. Entire network is hard wired. I have successfully transferred all my music files and playback is fine. Roon is fully functional. It’s just the frustrating Tidal login.

I have rebooted the SonicTransporter. Rebooted my iPad, restarted the Roon app. Done it all over again. No joy.

Any suggestions?

Hi Larry,

There is a bug that may be affecting the Sonic Transporter.

@AMP has found a workaround that may help. You need to do a double restart. Check this post.

See if that helps.

Cheers, Greg

Thanks for the quick response, on Christmas even. So far the work around has solved my issue. Thanks Greg.

1 Like

Guess I’m out of luck until you issue an update. The double restart worked once for about 24 hours. Now nothing will get Tidal to reload. My main reason for buying all this new equipment was for Roon and Tidal integration. Sure hope this get sorted out soon. From reading the other thread, there are several of us struggling with the same issue. Is there any purpose in me sending screen shots of logs? Can you give me any idea how long this will take to resolve?

Hi Mike,
I uploaded several versions of my log file. I am not sure if any of them will suit your needs. I don’t have access to the files on my sonicTransporter without going into terminal on my mac mini. I don’t know enough about Linux to even attempt that. I opened the log from the web page provided with the sonicTransporter and uploaded the log page. Converted that to a pdf. So you have multiple versions. Hope one will work for you.

I am using a new Sonic Transporter 8TB with a Sonore MicroRendu into a PS Audio DirectStream DAC.

I have no problem with playing my music files. Roon is functioning well. Sound is terrific. All my problems revolve around TIDAL. I was able to log in initially. Lost connection after the first day or so. Could not get back on. I went to your community site and got the advice to reboot the roon server two times in a row. That worked for a day and then lost connection again. Now I can’t log in regardless of how I try to get there.

The obvious stuff is all confirmed. I am logging in correctly and i can confirm that on my Mac Mini and on my iPad. No problem logging into Tidal on those devices.

Please let me know what else I can provide that may be of help to you. Hoping you have a solution or at least a work around that will work consistently

Thanks in advance for your willingness to help with my issues. Says a lot about who Roon is and where you plan to go.


@support - I too experienced this issue last night - lost connectivity to Tidal and to my Roon account. My roon CORE v1.2 is running on an i5 NUC, SSD, 8GB RAM, Ubuntu server 16.04, with NAS for my music library. Roon Bridge running on Pi3 all on gigabit backbone. Verizon FIOS 75MB internet.
No issues connecting to CORE, only to internet services - TIDAL and ROON Account.
Windows 10 PC runs Roon controller as does my iPAD. I was able to log into TIDAL on the Windows PC directly and did same for ROON Account.

Resolution: I had to reboot my NUC (at the OS level) 2x to get it working again with TIDAL and connecting to my ROON account.
I will double check again tonight.

Hi @Ian_Drachman ---- Thank you for the feedback and my apologies for the troubles here.

I wanted to reach out, to let you know that there are some known issues related to TIDAL, which are currently being investigated and worked on in house. With the release of 1.3 right around the corner we are making sure that these fixes are being tested and re-tested to minimize any chances of this happening again in the future. We greatly appreciate your patience!


Thanks Eric. I haven’t had a repeat of this issue, but other flaky items, such as initially selecting Tidal tracks for playing (on the playlist) and then are skipped. System returning with “Track is unavailable for play”. Yet, when I go to play directly, sometimes it works.
I look forward to v1.3.