Incorrect number of records for a composition

Roon Core Machine

Rock on Intel NUC, 16 GB

Networking Gear & Setup Details

Ethernet, connetced to FritzBox 7590

Connected Audio Devices

TEAC NT-505, Ethernet connection

Number of Tracks in Library


Description of Issue

I don’t think any details of the above are a possible source of the error, but you never know :wink:

I have a strange behaviour on both my iPad Pro and my Macbook. The same doesn’t happen on my Windows PC, so it might be app related.

Roon tells me that I have 69 recordings of the Symphonie fantastique in my collection

This is confirmed in the composition view:

When selecting the compositon from either starting point, I get this

in fact, it really displays only a single recording

Funny thing now - if I find another album of the Symphonie fantastique by album name, I still see the “69”.

When clicking on it, Roon takes me back to the composition page, only showing the Abbado recording.

What’s wrong here? I’m not aware of any filter I might have set accidentally.


If you go to Composers, select Berlioz, then Compositions, filter by “Symphonie” and finally select the composition “Symphonie fantastique”, you will be presented with the “All Recordings” page for this composition. Open the dropdown list under “Recordings by …” . At the bottom you will see an entry “Only complete recordings” which can be toggled to On/Off. If it is set to On, set it to Off and see what happens.
Please report about your findings.

@Andre_Gosselin Thanks for the hint. This did the trick. I don’t understand the root cause, though. I really have 69 complete recordings in my library. All local files. Why did Roon consider the Abbado complete but not the others?

I must have helped at least 10 users about the nasty consequences of “Only complete recordings” being set to “On”. I complained to Roon quite a few times about this feature, giving them many documented examples. Never received a proper answer from Roon people.
There are 2 problems about this setting. First, it is badly implemented and, as you noted, too frequently produces aberrant results which confuse the user. Secondly, this setting is a global one and applies to all recordings in your library, and as such should be moved to the Roon settings page. It is currently located in the worst possible place, hidden at the bottom of a dropdown list in composition recordings pages, suggesting that it is tied to a specific composition. Very bad design indeed.
May I call upon @support to finally solve this issue ?


Hi @Andre_Gosselin,

Scrolling through Community history, users have indeed reported this issue several times and for more than a few years without response. Allow me to get a status update on any internal efforts the team might have to address “Only Complete Recordings” toggling. I’ll clarify with the team, and then we can reclassify this post if necessary, since @Klaus_Kammerer1’s issue has at least been resolved by workaround.