Independent Power Control within Zone

Core Machine (Operating system/System info/Roon build number)

Linux /4.19.0-6-amd64 (Debian 10 64bit) VM on ESXi 6.7U3

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubiquiti Unifi (Ethernet):
ESXi (Intel NIC) ->USW-16-PoE …
…-> USW-Flex-Mini -> Naim Mu-so Qb
…-> USW-Flex -> US-8-60W -> Lyngdorf MP-50

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Naim Mu-so Qb - Ethernet
Lyngdorf MP-50 - Ethernet

Description Of Issue

Desired Outcome: Use either and/or both Roon Ready devices situated in adjacent rooms. Zone ensures synchronized playback when 2nd user powers up device assuming last input is Roon.

1 - Main Issue) Grouping devices into a Zone does not allow for independent power control. If I turn off one of the devices in the zone playback stops. If I press play it (attempts) to power device back on. Design implies independent power control as each device has its own power control. Device does turn off but so does playback.

Note: Squeezebox (SB) devices in their own grouping also does not allow for independent power control. I thought Roon did support this at some point on my setup. Roon on SB Radio barely works so I stopped trying to group SB… Missed the LMS feature so went with Roon Ready thinking it would be done

2-Secondary Issue) Roon control of the Lyngdorf MP-50 becomes unreliable when it is in a Zone. It will not always Power on and/or recognize Roon input (even if already selected). Maybe a time-out.

I’d split this post and put 1. In feature requests.

Hello @Rod_Hunt,

Welcome to the forum!

This is expected behavior. If you are playing to a group and Roon loses control to a device from the group the entire group stops playback. You are welcome to submit a feature request regarding improvements in this area.

Is the MP-50 connected to a managed switch? Managed switches have been trickier to get working properly with Roon, see Networking Best Practices Guide:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Thank you for the clarification. Based on prior experience with LMS/SB and how groups worked and power options I had assumed Roon worked in the same way. This is based on the existence of individual power controls for devices in a group. Although I can envision some cases where this could be useful it really seems to scream independent power control as the LMS/SB supported…

I will submit the request for independent power control with continued playback.

Thank you too for the managed switch information. I was aware of this in the past and had set my switches for Flow Control. Since that time I had to reset everything in the Network so it had reverted back to off. I have set them back just now.

1 Like

Thanks for the update @Rod_Hunt, do let us know how it goes with the new settings in place.

Flow control (FC) does indeed make a difference to the power on and change source for the MP-50. Without FC the MP-50 when Roon requests power on would:

  1. Not power on with Zone (recently powered off and still shutting down most likely).
  2. Fail to find/change source to Roon.

With FC the MP-50 power on control works correctly. First, power off MP-50 while on a HDMI input (not Roon). Second, within Roon, press play for the Zone while MP-50 is shutting down. Result is Roon gains control of the MP-50 and the zone is active.

As for main reason I created this ticket. I added my stuff to an existing request.

1 Like

Hi @Rod_Hunt,

Thanks for letting us know that with the Flow Control setting turned on the zone is working as expected!

I see you submitted your feedback on the feature request thread, so I’ll go ahead and close this thread out. Do let us know if we can assist with anything else and Happy Holidays!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.