Inexpensive “zone” for non-critical listening?

KEF wireless

I use a RPi with IQAudio DigiAMP+ hat and external speakers on a 19V SMPS from IQAudio…you can buy as a bundle too. Just pair with a set of speakers that meet the SWMBO requirements. I run with ropieee but diet pi is also fine.

build your own chassis if you like.

My other one is built into a sake bottle box driving a pair of Emotiva ERM 6.2’s most of the time

1 Like

I have very similar requirements along with wall mounting and am looking at either the Q acoustics 7000LRi or B&W M1 speakers - Dali Fazon Sat were mentioned on another thread but are outside my budget.

Thanks for the recommendation! Have you found a source for a pair of these in the US? I can only find them offered as part of a 5.1 set.

@John_McBride - I’m afraid not, I’m UK-based and they seem fairly easy to come by over here.

They look good! Pair of those and an RPi with optical out would be about the same as a BS Flex but would actually work properly with Roon.

1 Like

As a one-box solution, there is the Elac Discovery Z3, to connect via Wi-Fi or Ethernet cable.

It is a Roon-ready active speaker in one box. I am considering it for the kitchen.

Thanks for all of the suggestions! A couple of others I’ve come across over the past few days:

Genelec 8010 - these tings are tiny! Pros: standby mode if no signal is detected; no volume control on the speaker. Cons: only accept XLR connectors; not really “inexpensive” (~$600/pair); a little industrial in style.

IK iLoud: These seem to get pretty good reviews and I think I could disguise them pretty well on a bookshelf. But the reviews also suggest that they have a very tiny sweet spot

Nope… You can’t sync Kef Wireless, i.e. LS50 Wireless with other zones. LS50 Wireless buffer a reasonable amount of audio internally, in order to deliver that audio jitter-free to their internal D-As .They do not sync with other Roon endpoints.

I use Raspberry Pi’s feeding Audioengine speakers for my casual listening in the kitchen or bedroom.


Mine are analog in only, but I’m not sure if they make such a thing any more. You could use a HiFi Berry or IQ audio HAT with digital outputs. Or I suppose some speakers have USB DAC’s. Mine does have a USB for power, which doesn’t supply enough current for the Pi, and an auxiliary AC power socket I use for the wall wart to power the Pi.

There are many possibilities for all-in-one speaker systems, from building your own speakers and electronics from scratch to putting a Raspberry Pi or equivalent inside a commercial powered speaker. If I’m not mistaken Bluesound makes ready built Roon ready speakers, though I don’t know if they would meet your definition of inexpensive.

It appears that the Vanatoo Transparent Zero’s are good small form factor speakers. Unfortunately they are not (yet) available in Europe.

I ended up going with the Q Acoustics 3010:

I paired them with a RPi3 and a Hifiberry AMP2. Small footprint (these things are tiny!), fits perfectly on my bookshelf, and my wife is happy with them. The whole setup sounds pretty great given that it only cost around $300.

I’m using a Pulse Flex in combination with a Powernode2 (grouped or as separate zone) and it works perfectly fine with roon. What issue do you have with it?

@stevev1 Main issue is syncing, as referenced in Roon + Bluesound problems. Basically, as far as I can see the only grouping that works with BS devices, such that they stay in sync, is via the BS app - certainly that seems to be the experience of a few of us and is thus hopeless for combining with other devices. Is yours different? Would be really interesting to try to understand why if so.

Added to that, I have issues playing hires via Roon, in that it can cause a hard crash on the Flex - see Brian’s note on Seeking Help from Bluesound Node2 Users. Fortunately I don’t have much of it.

Finally, my experience of BS support has been good, until it involves Roon, at which point I have found myself feeling like a second class citizen. The problem is invariably blamed on Roon, with no attempt at offering useful support. It’s about a year since Bluesound added Roon support and to my recollection there’s been no attempt to keep pace with any RAAT changes in that time. Compare that to, for example, Lumin (not that I have any connection with them). Unfortunately, this experience has put me off buying another Bluesound product, despite their great sound (I have a Node 2 and a Flex). Instead, I’ve just received some ex-demo B&W M1s and a Pi-DigiAmp+ which I’m looking forward to setting up.

1 Like

I’m not having any syncing issues. The powernode2 is connected to my network via ethernet and the Flex is on wifi. Both are grouped within roon (not via BluOs). Previously I used a RAAT zone in the kitchen (rpi3 - dietpi) that was also grouped with the powernode2. I also never experienced any syncing issues with that set up. Both the Powernode2/Flex group and the Powernode2/rpi3 group always stay in sync.

I’m not having any issues with hires files or tidal streaming either. The MQA “problem” is indeed taking a long time to address. I hope the update to the latest RAAT version will come soon. Luckily MQA can be played perfectly from the BluOs app.

Perhaps it’s an issue with the Node2 specifically??

I can’t say much other then my setup just works as expected.

Well that’s certainly very interesting and shows that it can work, even with the old version of RAAT - thanks. Just to be clear, you can stop, pause etc at any sample rate and they stay in sync? If so, there must be an environmental component to this as well…by coincidence I was just in another thread discussing IGMP snooping…I wonder if it might be relevant here. OOI do you have it enabled or disabled in your environment?

Yes all that works fine but see below. Looked up IGMP and it is enabled by default on my router (TP Archer C3200)
I did some more testing to see if I could brake it…

  • Powernode2 (wired) + Flex (wifi) -> 2 zones stay in sync

  • Flex (wifi) + rpi3 (wired) -> 2 zones stay in sync

  • Powernode2 (wired) + rpi3 (wired) -> 2 zones stay in sync

  • Powernode2 (wired) + Flex (wifi) + rpi3 (wired) -> 3 zones stay in sync

  • Powernode2 (wired) + Flex (wifi) + rpi3 (wired) +rpi3 (wifi) -> things fall apart :slight_smile: The 4th zone (the rpi) on wifi is out of sync with the other 3.

So I guess it all depends on how many zones are playing and if they are on wifi or not… Hopefully a RAAT update will solve it.

Thanks so much for your time on looking at this - certainly your results are still much more successful than mine! Encouraging to hear that it may all be possible. I guess it probably makes sense to await the update and then retry. Given that you too have igmp enabled I think that’s probably a red herring.

You might be right about the Node 2, or perhaps it’s some network strangeness. I’ve just rejigged things around to setup new speakers & RPi. I now have a Flex and RPi on Wi-Fi via the same AP and they stay in sync. However, neither will stay in sync with the Node 2, which is connected via cable to the same switch.

Ah well, back to waiting I guess!