Initializing from Roon controller app when Roon core screen goes to powersaving mode

Core Machine (Operating system/System info/Roon build number)

Desktop pc, Intel i7, 8GB RAM, 512 GB SSD and 4 TB for data (music and others)
Windows 10 (1903), Roon 1.6 build 416 stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core machine is wired (gigabit ethernet). Other devices are on wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD C368 with BluOS 2i module
Cheap wireless speaker supporting Apple Airplay

Description Of Issue

Controller app (both on Android smartphone and Roon installation on laptop used as controller) are losing connection to core regulary (after not being active/opened). Music however keeps playing. When trying to select Roon core:

When waking the screen of the Windows 10 Roon core machine OR when connecting to the Windows 10 Roon core using Microsoft Remote Destkop, the connection from the Roon controller returns:

The Windows 10 Roon core machine is not hibernating nor going to stand-by at any moment. Only the screen turns blank after x-minutes (powersaving). As long as the Roon controller app is active, connection is not lost as well.

Hi @Tom_Glorieux,

Welcome to the forum. Do you by any chance have any firewalls on your Core PC? Is the behavior the same with these firewalls turned off if so? I have previously seen McAFee/Kaspersky/Windows Defender cause connection issues in the past, so I would verify this aspect.

For Windows Defender, you can use these instructions to check that both Roon.exe and RAATServer.exe have been added as exceptions. Roon.exe and RAATServer.exe can be found in the Database Location/Application folder path.

Also, please provide some more information regarding your network setup - info such as router model/manufacturer, any switches in use, powerline adapters, ect. can help clarify sources of issues.

I’m using Windows Defender. Exceptions for Roon.exe and RAATServer.exe are in place (added by option 1 mentioned in the instructions). Now I’ve disabled Windows Defender, but issues still persists from time to time …

The core machine is gigabit wired to a D-link DGS-5D gigabit switch. The D-Link switch is linked to my Fritzbox 9470 modem/router combo. Wireless devices connect to the Fritzbox.

I can however reproduce the problem over and over again following these steps. For this test, only the Android app was tested on one device. No other Roon remotes were active at the moment.

  1. On the Roon core machine: set power options so the screen is turned of after one minute of inactivity
  2. Close Roon remote app on Android.
  3. Wait one minute till screen is turned off
  4. Open Roon remote app on Android. I indefinitely tries to connect to the Roon core. When searching for other core’s, the actual core’s status is “initializing” as pictured in start post.
  5. Move the mouse of the Roon core machine. Immediatly, the Roon remote app re-establishes the connection to the Roon core.

The same steps can be performed, but instead of waiting when screen powers off (for this test one minute) using this script.

Hi @Tom_Glorieux,

Thank you for providing these reproduction steps, it is appreciated! I can file a ticket for the technical team to look further into this but I just want to confirm one thing before I do so.

In the past, we have had a few multicast issues reported with this router brand. In our Networking Best Practices Guide, we mention:

The FRITZ OS 7 update includes a feature called “Software Packet Acceleration” that can cause issues with remote connectivity. We recommend disabling this setting from the FRITZ GUI.

Can you check to see if you have this option to disable and if so, does the issue still remain the same?


Thanks for the suggestion, but I’ve already tried something else wich seems to be successful and may better suite my needs:

  1. Create a backup in Roon
  2. Removed Roon instalation
  3. Installed both Roon server and Roon from (didn’t even know both could be installed in the same machine)
  4. Used Roon as remote to connect to Roon server. Also configured Roon server to be started automatically upon logon wich comes in handy,
  5. Restored my backup

The issue that I had in de past seems to be completely absent now. I didn’t even had to change any settings on my Fritzbox modem/router or elsewere …

So the issue seems to be related to the Roon software as it only appears to be present when running Roon as all in one (control + core + output).
When splitting up in Roon server (core + output) and Roon (remote) the issue dissapears …

1 Like

Hi @Tom_Glorieux,

Glad to hear that the issue is resolved by using RoonServer!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.