Innuos Zenith MKIII as Roon Core does not see PS Audio Stellar Gain Cell DAC

I just setup the Innuos Zenith MKIII as a Roon Core (Server Integration: Roon Core with Squeezelite Player). The MKIII sees the PSA Stellar Gain Cell DAC (SGCD) without a problem. It is listed as “PS Audio USB Audio 2.0” and it is selected as the DAC in the MKIII as player output.

In the Roon Audio setup I see “PS Audio USB Audio 2.0” connected to Roon Core.
So far all is as expected.

However, when I try to enable the “PS Audio USB Audio 2.0” as an endpoint I get “Device not found error” and cannot activate it as an endpoint.

I had the same problem when I first got the PSA SGCD. At that time the Roon Core was running on a Mac Mini via the Pro-Ject Streambox S2 Ultra (Ethernet input and USB output to the SGCD). It turned out I needed to get the USB interface on the SGCD upgraded to support Linux. (The Pro-Ject Streambox runs VOLUMIO, which is Linux based). After the upgrade all worked excellent.

I replaced the MacMini because it is 10 years old and replaced it with a dedicated Roon Core, for the obvious reasons.

Does anyone have a similar configuration / issues?
Thanks for any input.
Greetings from Luxembourg!

Have you followed the instructions for configuring the experimental Roon/Squeezelite mode? They are here:

Your description suggests to me that you may not have, since you are trying to enable the DAC as endpoint. Once the experimental mode is enabled in, you need to open Settings in Roon, enable the squeezelite mode switch (under Setup), then (under Audio) disable the DAC and enable the squeezebox player. It’s also necessary to check the squeezebox player settings.

Thank you. That worked.
A little counter intuitive, but very straight forward.

Happy listening!!

Another question - probably of topic here in this thread.

I imported all my music from my old Roon Core (USB drive attached to a Mac Mini).
I would also like to import the playing history and tags etc. Is there a way to do that? I have Roon backups on that same USB Drive.


“Possibly”, if you have by luck followed this
You can restore a backup.

I will give that a try and report back.