Innuous Zen: Missing Method

I experienced similar problems.

First I could not play anything. Most tabs on Tidal where just giving waiting symbols. Others showed covers however nothing played.
I logged out of Tidal on Roon after I try to log in again it states: There was an unexpected error, please check your account details (Missing method).

I have tried to restart my Innuos Zen Roon server, but nothing helps.

Please advice


Hi @Lars_Schorling,

This error indicates that your Roon Remote is out of date. Please upgrade and make sure you’re on build 528 in the Roon Settings -> About tab.

But I am on 528 already and it states that it is the latest release.

Any other ideas?

Hi @Lars_Schorling,

The “Missing Method” error only occurs when your Roon Remotes are out of date. While you might have the newest version on the Core, I would check to see if you have the newest version on your Roon Remotes (the device you use to control the Zen).

Hi @noris,

I have checked both my iPad and iPhone and they both run on 528 so that was not the problem.
However, I then tried to uninstall the remotes and install them again and now everything works :slight_smile:

Many thanks for your help.


1 Like

That’s great news @Lars_Schorling, happy to help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.