Input/output error for watched folders in Mac Book Pro with Roon Server on Sonic Transporter

I have just moved my Roon server to a Sonic Transporter. I’ve successfully attached my Synology NAS as a watched folder. Now I am trying to add watched folders from my Mac Book Pro. But I don’t seem to be having any luck. The closest I get is to having the folder listed as watched, but with a red letter “input/output error”. What does this mean, and how do I fix the error? What is the kind of network path that I’m supposed to use?

@Carl I wonder if you can help with this? Or know someone who can?

Hi Anthony, I have little experience with Macs so I’m not the best guy to help you here … so this is only a rough guide:

  • You need to setup an SMB network share on the Mac, so that the folder containing the audio on that Mac can be seen via the network.

  • Once done, then in Roon add a watched folder using the networked section of the form.

Perhaps you could upload some screen shots and detail of the network share you are attempting to use.

I’ll leave a flag for @support, to follow up with you … or may by a Mac savvy Roon user can help.

Hey @Anthony_Langlois – why don’t you walk through these steps and let us know how it goes. They reference Lion but I don’t think things have changed too much.

Just flag @support if you get stuck. Thanks!

Thanks @support for that, although as far as I can see I have had the file sharing set up correctly throughout. I should have said that earlier. The closest I can get to contact is “permission denied” That happens when I put dashes in place of the spaces in my user name for the computer. When the spaces are there I get the input/output error.

(@andybob this is my current problem…).

Mac’s aren’t my bag sorry, but Mike should see you right.

Can you explain exactly how you’re adding that folder?

My expectation is that in Roon you would be typing the IP address you’re seeing in your Mac’s file sharing screen:

In most cases, you would also need to type the user name and password you used to share that folder.

You should be able to test this is working on any other Mac in your home, by going to Finder and selecting Connect To Server in the Go menu. Then, use that same IP address, user name, and password to confirm that the file sharing you set up on your Mac is working properly.

Let us know exactly what steps you’re taking to add the folder shown in your screenshot above, and we’ll go from there.

SO here is what the file sharing looks like:

So I use that smb etc and then I go to the file and copy and paste the yellow highlighted bit you will see for the path to the folder:

I have tried some variations. With and without the period at the end of the smb address in the first screen shot. Substituting dashes for spaces in my computers name where roon asks for username and password (this does seem to change whether the error I get is the inout/output error or the permission denied error). So if you have any advice on those specifics too… I can’t test using the other mac in the house right now as its owner is asleep and I don’t remember the password :frowning: … But part of the reason this is mystifying me is that I had previously, successfully, managed to add a folder from his computer to roon when the roon core was running on my computer, not on the sonic transporter.

Is it possible that the problem is being caused by trying to add the folder from the computer I’m trying to add it from, for some reason (would seem a serious limitation if so! and seems unlikely).

Anyway, doing that, I end up with this:

Which gives me this:

Could you try using the Mac’s IP address, rather than the hostname?

No change.
I still get the difference between input/output error and permission denied when I put dashes instead of spaces in my user name. What is that about?

I think that this is a problem with the username. The smb implementation in Linux is pretty strict whereas apple’s implementation is a bit loose. The spaces in the username that you’re using may be causing the issue.

First off you need to find out your login ID on the mac. Based on the screenshots you’ve posted I’m guessing that this is “Langlois” but it’s worth checking for certain…

On the Mac open a terminal window (Applications -> Utilities -> Terminal)

At the prompt type “whoami” without the quotes. This will return your user ID or short username. Use this as your username in the login window within Roon. This is case sensitive.

So it was “Langlois” as you guessed . But if I use this then in Roon, I still get the input/output error.

OK. Now go to the File Sharing control panel on the mac and click on “Options…”

Make sure that “Share Files and Folders using SMB” is checked.

Some SMB clients authenticate differently and require you to specifically authorize a user. In lower half of that box check:

  • If the box next to your username is not checked then check it. You will be prompted for a password.
  • If the box next to your username is checked then uncheck and re-check it. You will be prompted to enter your password both when you uncheck and check it.

(and in looking at this again…)

I think that you may have an error in the path that you’re trying to mount. You don’t need the /Users prefix on the path.

It should be: smb://anthonylanglois/Langlois/Music/iTunes on Mac/iTunes Media

This may be the whole problem, but worth checking the items above as well.



Many thanks for your help. I think it was the “users” in the path, as you suggest.

many thanks for your help Andrew (and Mike and the others who have pitched in!!)


Good deal. Glad it got resolved!