Install ROCK On a Mac Mini

So After many attempts at installing Ubunto and failing on Mac mini i decided to give Rock a try on Mac Mini 2012 and easy peasy. I used a USB network adapter and off it went, So to those wondering that have a mini. Yes installs easy if you have a USB ethernet

2 Likes

Why would you want to do that as there is s Roon Server software version available for macOS? I am just curious to understand.

BR,
Richard

One possible reason might be that 2012 Mac mini doesn’t support Roon 2.0 when using macOS, whereas it does when using Linux.

Aha, that explains it. I use OpenCore Legacy Patcher to run macOS Monterey on my 2011 headless Mac Mini, which works perfectly with Roon 2.0.

BR,
Richard

Thats exactly it and the Mac Mini wasnt being used for anything. Originally I had planned on installing Ubunto on it and then server, however the install kept failing and I decided to just try Rock see if it would go. It did.

I also tried the open core patcher and it kept getting stuck at the loading screen saying it would be done in 1 minute for like hours. Seemed like something was wrong. Then Ubunto kepts saying install was damaged etc. This was mostly just an experiment and a Trial run.

I experienced something similar on my Mac Mini with OCP version 0.4.11, but with 0.4.6 the install went flawless and afterwards the upgrade to 0,4.11 went really easy as well. You can download older OCP versions easily from the GitHub site.

BR,
Richard

2 Likes

How did you do it? I’m wondering if I could do this on my 2010 Mac Mini. I currently have it setup with Ubuntu which unfortunately doesn’t support audio through the HDMI port (Linux driver issue, GeForce graphics card not fully suppported). So I am considering my options; Nucleus, NUC or a newer Mini. ROCK on my existing Mini would be great :slight_smile:

Well not sure what happened but now its not picking up my IP adress. Ive tried reinstalling Rock and it just says failure to find IP. Im using a TP link USB ethernet adapter.So odd how it worked fine for 24 hrs now this. Weird. May go the update Mini OS using the oclp patcher and run Roon server. Strange.

Ok - thanks for the feedback. Think I will also give the patcher a try :slight_smile:

i‘m using ubuntu server on a mac mini 2012 since years.
currently version 22.04.1 lts runs rock solid with roon 2.0.

The problem I have is that Ubuntu / Linux is not compatible with my 2010 Mac Mini GeForce graphics/sound card meaning no Audio support over HDMI. And the mini / roon core is connected to my Denon AVR to enable high res audio output incl. multichannel. Guess it’s not an issue on the 2012 Mini

my answer was meant for shawn :wink:
it works with usb and via ethernet to the streamer.

What are you using, as USB stick? Did you do the ‘csrutil disable’ step? I have Roon 2.0 working perfectly with Catalina 10.15.7 on my mid-2011 Mini, playing through a Dragonfly Red DAC. Also headless.

I got it running, wasnt thrilled with performance on Monterey. Im running linux and roon server. On one drive and Rock on other but it looses the IP as in the USB ethernet adapter stops working. Its a TP link 1gb model

1 Like

Oof, wonder why. Is it using DHCP? Could be the energy-saving settings. Tried setting a static IP?
Why not use the onboard Ethernet, is it not Gigabit?
Mine is on WiFi and streaming just fine over that.