Install x86 RoonBridge on Linux [Ticket In]

Hi everyone!

I’m new to Roon and having trouble installing RoonBridge on a Ubuntu Linux Machine with 32 bit in version 18.04.5. I followed the official guide and got the in root. When I try accessing it I get the following error message:

Unpacking RoonBridge_linuxx86.tar.bz2… This doesn’t look like a Tar archive.

Bzip2: (stdin) is not a bzip2 file
Tar: child returned status 2

I checked for bzip2, it is installed.

Can anybody please give me a hint what needs to be changed?

Thank you!

Having same issue. When downloaded, x86 tar for roon bridge for linux is only 178 bytes.

All other tars for linux bridge are in the 14mb range.

Noob here, was excited about getting going, but now bummed that encountered this issue when just getting started – frustrating. (Not to mention wasting time second-guessing myself.)

Thank you for your reply. Good to know I’m not the only one struggling with that particular setup. Let’s hope we get some kind of advice from more experienced users or tech support.

tagging @support.


64-bit linux user here, but figured I’d give it a look anyway.

If you look closely, those 178 bytes are a 404 message from the web server.

The 32-bit .tar.bz2 is missing, which can also be confirmed at
by clicking on the “manual install” direct download link.

So I guess someone at Roon needs to actually publish the tar file…

1 Like

Hey Manny,

Thanks for your response.

Little doubt what is wrong (missing file).

Now if only Roon support would chime in…

Bump @support.

I’m at day 10 of my 14 day free trial. The weekend looms.

Any hope of even an ETA so we can prioritize our time?

Can we expect response in days? Weeks?

Hi All,

Thanks for the reports, we’re looking into this.

Hi Noris!

Thank you for your reply. Any update on this issue so far?

Does this work for you, I just tried it and it worked perfectly. Can you use the 64 bit installer?

$ curl -O
$ chmod +x
$ sudo ./

$ sudo apt-get install ffmpeg

I’m afraid I need the 32 bit version for this device.

@support / @noris,

issue now 17 days old.

ETA? hopeless?

PLEASE advise?!?!?

Hey @Nunuv_Yerbiz,

Thanks for staying connected on this thread - this issue is still in our QA team’s queue, that is slightly longer than normal.

We haven’t overlooked this issue. One of us will reach back out with an update as soon as we have it.

So sorry for the wait - it is longer than we had hoped :pray:


almost 2 more weeks?

i purchased new hardware that’s running the roon core that the 30 day return window already closed on.

if you folks can’t get this bridge issue resolved, that hardware’s value is significantly reduced.

PLEASE resolve – or acknowledge that there will be no resolution. (maybe 32 bit linux is a goner with roon?)

Hello @Nunuv_Yerbiz ,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a ticket with our developers.

Upon initial investigation, it looks like there will be a significant amount of changes needed to resolve this issue, meaning, while we have this issue in our queue, I cannot specify a timeline of when it will reach the top of the queue, it may take some time.

The issue is in the queue and your patience here while it makes it’s way through the dev queue is appreciated!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.