Installation fail under Windows 10

Roon Core Machine

Hi there,
i can’t install roon, after i deinstalled it because of an issue i hoped to solve that way. it didn’t.
After i start the Rooninstaller64 it is telling me, that i am missing .NET framework 4.5 and then it tries unsucessfully to download and install it. I tried installing the newest version of .NET framework, but windows is telling me, that i already is installed and running. deinstalling and reinstalling of .NET framework didnt do the trick eighter.

any ideas?

Maybe try downloading it again from Microsoft and delete the original version. see what happens when you install it from there. I haven’t put a link below for you to try. That should hopefully mean Roon does not need to download and install it then and will hopefully work for you.

1 Like

thanks for your message. Indeed, i have already tried that. i deinstalled .NET Framework, restarted, tried to install .NET Framework 4.5, but it tells me, that i already have .NET Framework as part of my operation system.
any other ideas…?

So Dot Net is also an optional OS install.
You can go to Control Panel, and add remove programs and maybe uninstall it as a Windows feature component and then try installing it again

1 Like

Hey @Michael_Harris thanks for the great advice here :pray: !

Hey @Martial_Boni,

We’re sorry about the trouble and grateful that you reached out. Did the final steps suggested by @Michael_Harris help? Is there any progress or can we help at all?

hello @Michael_Harris and @beka, thank you both for the help an reaching out.
i had lots of stress and couldn’t work on the persisting problem with the roon installation.
So as response to your last post: i had deinstalled .NET Framework as part of the operational System of Windows, in the programs and features panel: turn windows features on or of. Then i rebooted the pc. When i search for .net or framework i dont find anything on my system now. Still i get the same answer when i want to install the 4.5 version from the provided link:
Microsoft .NET Framework 4.5 is already a part of this operating system. You do not need to install the .NET Framework 4.5 redistributable.
Same or higher version of .NET Framework 4.5 has already been installed on this computer.
any more ideas where .NET Framework is hiding on my system, or if it is related to another problem, just remotely related to .NET…?

Hey @Martial_Boni,

It’s good to hear back from you!

Thanks for going through all those steps. While installing .NET on a Windows machine isn’t really our area of expertise, I have found some information that might be helpful:

It turns out that .NET 4.5 will not appear in Control Panel as in previous versions. It has files spread across Your Drive:\Windows.

Have you tried reinstalling Roon after going through the above steps? Do you see the same error?

If so, Microsoft has some information on how to address this below:

.NET frameworks are installed by Windows installs

You may have a corrupted install. Download the installer from ~Microsoft and choose the Repair option

Worth a try

1 Like

Hi Martial you can remove and re-install the DotNet framework from within Windows control panel, Programs and features. See if you can uninstall it from here and then re-enable it (mine is now Windows 11 so yours might say something slightly different.
Windows updates DotNet through Windows updates, so it is possible something went wrong.


thank you all for your help. unfortunately the problem still persists.
@Michael_Harris thank you, but that’s the first thing i have tried.
@Mike_O_Neill i run the repair program, and it did something

It just didnt do the trick. Still the same error message while installing roon. could still not install a previous version of .NET Framework though.
@beka as far as i read from your provided links, it is a problem that also others have failed to solve. one way that solved someones problem was a complete reinstallation of windows. i would really like to avoid this. any other ideas? im super annoyed…

I was going to say that a reset of Windows might resolve the problem. I’m not sure much else will help sorry

Hey @Martial_Boni,

I am so grateful for your dedication in trying to figure this out…

I wish I had more insights to share at this point. I’m unsure of the other options to fix a defective .NET installation on Windows. Based on what I’ve seen so far, an OS reinstall is the solution, as @Michael_Harris has mentioned as well.

Before going this far, at least establish whether this is a correctable corruption problem.

Right click the Windows button, click on Command Prompt (Admin), and enter ’ DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH '. After that completes, enter ’ SFC /SCANNOW ’ If either reported errors that it could not correct or did not report any corruption but the problem still exists., then yes, you may need to perform a Windows Reset or reinstall.

If right clicking the Windows button doesn’t give you a command prompt option, regular click the Windows button and enter ’ Command ', then on the right side of the Command prompt pop-up that appears, click ’ Run as administrator ', and run the two commands given above.

After executing the two commands in the previous post, reboot Windows.

Just a thought , are you all up to date on Windows Updates ? They seem to happen almost monthly .

Sometimes the updates play around with Drivers , reinstalling the video driver in particular with the Original Manufacturers one has proved useful on occasions here.

The .NET framework 4.5 is OLD , maybe that’s why. My PC is my ex development PC so is hardly typical as I have every .NET framework and NET Core etc going on it. My Roon install has been there for 4 years without a blip.

It looks like a file corruption issue , but more than that .

Last ditch , try uninstall Roon, Reboot the PC and then try the Repair tool again and Reboot between tries. Can’t beat a good reboot :smiling_imp:

thank you all for the combined effort. i do appreciate that.
@Peter_Gettinger i run both commands, both did some corrections successfully as far as the log goes.
@Mike_O_Neill My updates are all up to date. Roon is uninstalled and i rebooted nonstop over all my tries.
So i guess i have to face it and just reinstall windows :roll_eyes:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.