Installed new mesh WiFi system, Roon zones vanished

I’m not familiar with the Eero system (I use a bunch of Deco M9’s), so can’t advise in any more detail, but @wklie’s point is worth checking, i.e. make sure that your core is on the same network as the different zones. If not, there’s no way they’ll be able to task to one another.

The modem comes from my ISP, but everything else is Eero (3 Eero devices serve both as my primary router and as WAP/extenders). There’s only one Eero network.

Thanks for taking the time to answer.

In which case I hope support have something useful to add. Good luck.

1 Like

Many ISP modem nowadays is actually also a router. Find out the modem brand and model.

How is your MacBook Pro connected to the network? WiFi?

Disable the Mac Firewall.

Is the modem a WiFi access point, also? If so, turn off the WiFi in the modem and make sure your devices are connecting to the mesh network. I have been using Eero Pro system for a while and it works well. The eero does not necessarily need to be in bridged mode as someone earlier stated. You just need to make sure the devices are all on the same network (WiFi and wired).

It’s not really a modem, it’s a POE injector. I never set up the Mac Firewall.

My Macbook Pro (which is where the core is) is connected to the network wirelessly – I have no ethernet connections anywhere on my network, it’s not possible for me to get a wired connection.

It’s not a modem, it’s a POE injector that’s connected to my Eero router with an ethernet cable. Otherwise there are no wired connections on my network.

That sounds similar to what I have now I think, I was just upgraded to fiber in the house and there is no modem anymore just an ethernet cable from the ISP. When you installed the Eero did you use the same SSID (WiFi network name) and settings as what was on the airport extreme?

Although, I have my core wired to the eero via ethernet and use a switch to wire the components together. I only use wireless for control/remotes.

This may be silly but the zones will only show up if Roon (remote) is actually running on the iPhones and iPads.

While that may have worked in the past ( although from one of your posts never trouble free) it is not Roon recommended practice to have the core on WiFi.
It will only cause problems down the road.
I know that does not help with your present issue but it should be taken into account for the future.

If your Eero devices have an Ethernet port that may be a way of connecting the core via Ethernet.

Is that an Eero 6 or Eero 5 Pro? I believe multiple users here have Eero 5 Pro working in Roon.

This post documents problems with Eero 6:

Assuming you still have the Apple router, restore it for routing and DHCP services, but disable the WiFi. Turn the Eero into bridge mode.

here is a FAQ on putting eero into bridge mode:

Key points are that you can no longer manage advanced features (eero secure and advanced network settings through the app, etc) and at least one eero is required to be wired to the router when you do this. They recommend putting the upstream router/modem into bridge mode not the eero so that you can still use the advanced features.

I have an Eero 5.

I don’t have flexibility about placement of the router and because of that, nothing is or every has been connected by ethernet to the network (my Roon core has been connected by wifi for the past year). The previous Apple Airport wifi network was on-the-whole infuriatingly unstable, but Roon worked fine.

From comments here, it does sound like I could tinker with the network some more and if I get it just right, Roon might work, but to be honest, I’m blown away that the Eero system is working for me out-of-the-box, without tinkering. Roon is the only thing that is NOT working so I’m now thinking, as sad as I am to give it up, Roon will be the one casualty of finally having a wifi network that just works.

I just noticed that you said there are “Airport Expresses that are still on the network”. Are they still trying serve as access points (APs). In other words, is wifi routing/DHCP still turned on in these units and are they serving up their own separate wifi networks? If so, they may be what is causing confusion in the network as to where things are connecting over wifi. You might try turning off all devices that could possibly serve as a wifi AP and only leave the eero network on.

Is there a reason you would still need the Airport expresses if the eero is what is serving as your wifi network?

Also, to restate it, This may be silly but, the zones will only show up if Roon (remote) is actually running on the iPhones and iPads. Did you try starting Roon on your iPhone and/or iPad and see if it sees the Roon server that is running on the core machine? This is just me digging for more info and to make sure we understand what you are seeing.

Just to check, when you say in your original post that your zones have disappeared, do you mean they have disappeared from the zone picker (bottom right of the Roon control app screen) or that they’ve disappeared from the audio section of setup? If it’s the former you may just need to re-enable them in Setup → Audio. I suspect this isn’t the case, i.e. you’ve checked, and they’re not visible in the settings either, but re-reading your original post made me wonder.

@JM_in_SF I have a very similar setup to yours - replaced a dying Airport last year with several Eero devices. I read the Roon advice and set up Eero in “Bridge” mode from the start (Eero app Settings → Network settings → DHCP & NAT). Everything works fine, and like you I’m thrilled with Eero’s great wifi in the house.

I never noticed it before, but when the Roon app is up on my iPad, it does show up in the Roon app on my Mac under Settings → Audio. The iPad does not appear in the Audio Zone chooser at the bottom-right corner of the app, though. So I’m not sure why this matters. Does the Roon app work on your iPad?

I changed the network name when I installed Eero, and turned off the Airport. I do still run an Airport Express, though, connected to the new network, and I occasionally play music from its 3.5mm port to a portable speaker. My Roon core is wifi only - not recommended, they say, but it works fine for me. Maybe try the Eero bridge mode - you could probably just switch back if something was interrupted when you did that.

Right, not available in the audio section of setup either.

1 Like

The Roon app on my iPhone & iPads does recognize the Roon server (although, under Settings, if I try to “Find” the Roon OS, it hangs – this is true on my iPad, my iPhone and even on the laptop where the Roon core is located), but neither is recognized as a zone.

I use the Airport Expresses to stream music through the audio port to an external amplifier that’s connected to speakers.

I got a message from Roon tech support with some things to try. Busy day today, I won’t get to any of this until tomorrow. Sincere thanks for engaging with me on this!

1 Like

As I mentioned in a reply to a different poster, I received a message from Roon tech support today with some things to try.

I use the Airport Expresses as you do – to stream audio through the 3.5 mm port to separate small stereo systems (people often say “Why don’t you just get a Sonos system or somesuch” and the answer is “I invested a lot of time and $$ in my speakers and I like them, am not ready to give them up.”

At least I can stream Tidal directly to the Airport Expresses, without Roon.

Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.