Installed on Linux, where do I go to use it?

The Linux install directions have left me hanging:

I’ve run the installer script, it says “All Done! RoonServer should be running on your machine now.”

Great… where do I go next? Going to its ip address shows my normal Apache installation on port 80.

I tried cat /var/roon/RoonServer/Logs/RoonServer_log.txt, which shows this error:
12/08 06:14:23 Warn: Error in web request NetworkError (Aborted.)

Doing curl shows

504 Gateway Time-out

504 Gateway Time-out

nginx/1.4.6 (Ubuntu)

Is Roon’s server down?

I see in the logs “HTTP server listening on port 9100” - tried going to its ip at that port and it returns a 404 error, so it’s listening and sending that error code back.

I’ve poked around in my account options here and don’t see that it’s connected to it. I feel like I’m missing the obvious next step. Thanks!

I’ve installed the Rune client on my Windows desktop, it’s endlessly searching for the server. I even plugged in the IP manually and it doesn’t see it. The Linux machine has no firewall on it, it’s here on my LAN. It’s running Ubuntu 16.04 in an lxc container. Thanks!

RoonServer has no interface, it is configured by a Control on another machine on the same subnet. Just start a version of Roon on another Mac or PC, or a Roon app on a tablet or phone and point it at the Core on the Linux machine.

Enable Roon and RAATServer processes on your Windows firewall and restart everything.

Check what processes are running on your Linux Core with:

ps aux | less

Thanks. My iPhone is able to see the roon server so I’ve configured on there, the desktop is not. I saw some inbound firewall blocks in Windows for roon and rattserver and told those to allow, rebooted, still the same. Tried disabling windows firewall, same result.

They’re both on different subnets (iphone & desktop, server is on 10.0.5.xx, but subnet masks are and all sorts of other apps are happily talking). I tried changing one of the NICs on my desktop to be 10.0.5.xx, doesn’t seem to have helped. My iPhone sees the audio devices available on my desktop.

When I rebooted the server roon may not have auto launched, my iPhone only saw it once I ran manually. But that’s not a big deal for now, will try to confirm that later.

How would I go about setting up access to stream over the internet? Can I forward a few ports to my server, or do I need to be in a VPN or something?


Controls have to be on the same subnet as the Core in order to discover it.

VPNs have worked for some, search VPN on the forum and you’ll see various threads.

This KB page has a link to port forwarding info.

That link’s broken @andybob

Thanks Steve, fixed now.

Info in the linked post from Brian is:

… you’ll want to forward:

UDP port 9003
TCP ports 9100-9200