Installing Roon ROCK - Can't boot from USB drive

Roon Core Machine

Intel NUC8i5BEH

Networking Gear & Setup Details


Connected Audio Devices

NAD M33 Integrated Amplifier

Number of Tracks in Library

Description of Issue

Trying to install ROON ROCK on Intel NUC8i5BEH. BIOS detects all, USB drive, M2 and SSD drives.

When booting to a SanDisk 2.0 USB drive (with SecureBoot disabled, etc., etc.) it flashes once and comes back to same page. I followed all instructions on setting up BIOS, and nothing will let me install ROON ROCK. Tried burning bootable images with Rufus and Echer. No go.

Any assistance please?

Which ports are you trying to use? front or rear? I have seen some have issues with the front… YMMV
I guess the point is, try a different port (i.e. different USB bus)

Has the BIOS been updated?
Also, just to be sure (from the KB):
Set the proper Boot Settings (you may need to click “Advanced” first):

  1. Disable Secure Boot
  2. Make sure UEFI is enabled on the Boot Priority screen
  3. Set the boot order to boot from your SSD first (you can drag the drives into the proper order if you’re using a mouse. Otherwise you can use the + and - keys)
  4. Disable Network Boot
  5. Enable USB Boot but make sure the SSD has boot priority
  6. You may need to enable the M.2 slot, depending on the BIOS version
  7. Save your BIOS changes
1 Like

All done. Tried Win 10 bootable USB and it booted now fine. Still having issues with Rufus and Etcher created bootable Roon ROCK…

Something is seriously messed up with this NUC. I disconnected SATA drive (temporarily) and removed SanDisk Cruise 16GB USB pen drive. No go. BIOS in UEFI section still shows SanDisk USB drive even though it’s not even connected!!!

I am losing my mind…

you might try resetting the BIOS to factory default and starting over?

Do you mean load defaults? If so, did that twice already.

Hi @Damian_Styga ,

Are you running an older version of the BIOS, can you try to update it to the latest BIOS version for your NUC model? You should be able to locate it here:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.