Intel NUC 11th Gen Iris Xe Graphics was working but now receiving OpenGL error message (could not find WGL functions)

I have an Intel NUC11PAHi7 that i use as a Roon End Point only (core is installed on a separate NUC running Roon ROCK and this is working fine).

The end point is running Roon v1.8 (build 882) and the NUC is running latest driver versions for everything including Iris Xe graphics.

Up until today i have not had a problem running Roon on the NUC11 end point but on starting Roon today i received an error message, screen shot is included. Note, I have no issue with Roon App on IPad.

I have not changed any hardware or settings but have in the past week applied Windows updates. I do recall a message to update devices when i was using my IPad a few days ago, which i did.

I have found some posts in support that are similar to the error message i have received but all these appear to be resolved by identifying either out of date equipment or requiring driver updates, neither of which apply in this case.

I have attempted to install Iris Xe drivers again but installer is reporting drivers are uip to date already. I have no other error messages or issues with other software.

I am fairly computer literate and have tried everything i can think of other than a physical rollback of driver installations.

Please help, any advice welcome!

Roll back the drivers if you can. The very latest drivers seem to be the issue

Damn was hoping not to have to do that but will give it a go thank you

Device manager was showing an issue involving unsigned drivers under Display Adaptors. I have rebooted the NUC using recovery and selected option to install drivers that are unsigned. Once rebooted i tried again to install Iris Xe drivers, this time it worked and the error message has gone from Device Manager Display Adaptors. Roon now launches ok :grinning:

Note to any Roon users who have Denafrips DACs and DDCs. There is a new USB driver available that can only be installed by going through a restart via recovery and installing unsigned drivers. This is what i did a couple of days ago to update my Hermes DDC. I had no idea that it would lead to a problem with graphics!

Will post message on Denafrips support

If it’s endpoint only run Bridge

(All Downloads here Roon Software Downloads - PC, Mac, Linux, Android & iOS | Get it Now)

I don’t believe Bridge has any dependency on graphics.

1 Like

Intel installer or Microsoft Windows update?

If you were using the Intel installer, see if you can completely uninstall the display drivers, then manually install an older driver from Intel website.

I moved this thread to support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.