Intel NUC died out of nowhere

Core Machine (Operating system/System info/Roon build number)

Intel NUC8I3BEK2 with SSD, RAM configured as recommended by Roon.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Fritzbox router, Intel Nuc connected directly to Fritzbox

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ropiee XL based on Rasp 4 as streamer, connected to RME ADI2 DAC

Description Of Issue

Dear all,

my Intel NUC 8i3BEK2 is running Roon Rock (as Core) with out any problems since May 2019. Out of nowhere, the NUC/Roon Core was not visible anymore. I plugged the NUC via HDMI to monitor which then indicate that the NUC does not boot correctly. In particular, the NUC boots with the Intel Logo on screen, nothing happen, after 25 sec it shut down and reboots again showing following error message:

BIOS has detected unsuccessful POST attempt (s) … Possible causes include resent changes to BIOS Performance Options or recent hardware change. Press ‘Y’ to enter Setup or ‘N’ to cancel and attempt to boot with previous settings

My keyboard does not work, so i am not able to choose a option. Shutting down the NUC replicates the booting loop. I do not get into the BIOS. I noticed that during the first boot no little yellow light is flashing but after the reboot the yellow (battery?) light flashes constantly (see picture attached).

What i did so far:

The recovery process is successfully carried out but the problems (faulty boot, reboot cycle, no keyboard functionality) remain the same.

At the moment, I do not know how to proceed further. I read in a different forum to use an older .bio file.

For me its a bit shocking that this happened out of nowhere and I am not able to get the system running again.

Hope anybody can jump in and help me to get the issue solved.

Thanks a lot in advance


Power down the unit. See if there is a battery. Remove it. Then short the clear CMOS jumper for a few seconds. Put the battery back.

Power up the unit, if you can go into BIOS, reload BIOS default. Also observe whether the CPU fan is running.

1 Like

Are you using a wired usb keyboard? If so try a different usb port. You really need to get a keyboard working to get into setup.

1 Like

The error can occur with attached storage. You did not mention it, but, if you have external storage, try unplugging it and rebooting.

Also, review the following:


I have no external drive attached.

I had just for testing reasons an external drive attached a few month ago. But I removed it then. Could that be the reasons for the error?

The hints in the link are not helpful as I do not get into the bios because my wired keyboard does not work - tried all usb ports…

Try this


Thanks for the replies so far.

I found out that when I remove the M2 SSD from the system, I can get into the BIOS and my keyboard is working. This narrows down the problem.

Do you think the SSD is defect?

I use a Transcend 128GB Nvme PCIe Gen3 X4 MTE110S M.2 SSD Solid State Drive TS128GMTE110S.

When I install the ssd again, I get stuck on the Intel Logo Screen in which I should choose from the three option F2 enter Uefi…etc. Here my keyboard does not work anymore and I cant get into the uefi.

Help is more than welcome :slight_smile:

Well, I notice that this particular M.2 SSD card is not listed in the Intel Compatibility Tool. Personally, I think I would source components that are named in this list.

Thanks, but why is this then recommended by the roon folks for the ROCK?

Very good question, and the answer is I don’t know. Something for @support to respond to, I think.

1 Like

Please get a better brand of SSD, regardless of whether it’s in or not in any list. Please do a search here and see what SSD others are using.

1 Like

Case in point. I only use Samsung. Looking on Amazon: Samsung 970 EVO Plus SSD 250GB - M.2 NVMe (MZ-V7S250B/AM) is way big for the job, but also not very pricey, imho.

1 Like

It could simply be that the SSD failed. And you just need to replace it??

1 Like

Indeed, this is what I did, ordered a Samsung M2 SSD.

Lets see if the NUC performs correctly with the new drive.

I ll report back!

Received the new SSD. Installed it. Nuc sees the drive.

I installed ROCK again and everything is smooth as before.

Just two remarks.

(1) I do not whether the error occured because I used a relatively low priced SSD or there was a different problem.
(2) A reason for the failure could lie in the fact that I do not disabled USB boot first in the BIOS. As my M2 SSD drive was not selectable as a boot drive, I installed ROCK via USB and after the process I directly went in the BIOS again and disabled the USB boot option. @support: I think it make sense to update the installation guide for Intel NUC 8th Generation users.


SSDs do fail occasionally. I had a Samsung SSD go bad on me a couple of years ago. Rare, but not entirely unknown.

And SSDs are made from different memory types, some of which are more robust than others.

When you pulled out the SSD, the keyboard became working again is a clear indication that your previous SSD is defective.

@Geoff_Coupe I’d not call SSD failure to be occasional. Personally I actually believe they fail more than mechanical HDD, in ways that are much less recoverable, and with no useful SMART warning beforehand. HDD often has bad sectors increasing, makes strange mechanical sounds like click of death, etc. SSD just dies.

Very true, and I’d recommend buying SSD only from brands that manufacture their own NAND chips.

I’d add, be careful about using QLC memory based SSDs, as well. Maybe for long term storage, but, I wouldn’t use them for the OS/Database drive.