Intermiitent jitter suddenly occurs


(wilfred walsh) #1

Core Machine (Operating system/System info/Roon build number)

QNAP TVS871 using latest roon build as of 20MAR19 with roon database on an attached solid state storage device.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired ethernet. Netcomm router NF18ACV. A fairly standard home internet setup.
.
Audio Devices (Specify connection type - USB/HDMI/ect.)

Devialet expert 440 connected via ethernet cables going through a switch.

Description Of Issue

Set this system up (for the first time) with roon core on the qnap NAS and got it working perfectly for a couple of days. However a day later the system is unsable due to jitters when playing either tidal or library files. ie music plays for a few seconds then stops and restarts. Completely impossible to listen to anything.

I have rebooted all devices in various sequences and checked no device is busy with CPU, disk or networking operations.

Not sure what else I can do - saw a forum post that implied the ISP might be doing something problematic, but that seems unlikely if library files also afflicted? Any thoughts on what to do next appreciated, as otherwise roon is of no use to me.


(Noris) #3

Hello @wilfred_Walsh,

Thanks for contacting us regarding this issue, I’d be happy to troubleshoot with you here. I have a few questions starting off:

  • Can you please confirm if you are using the Devialet Air or Devialet RAAT protocol to stream to the endpoint?

  • What is the model/manufacturer of your switch?

  • Have you tried rebooting the Core, Networking gear and endpoint yet? I would give this a try.

  • I noticed that your QNAP NAS model has two Ethernet ports, can you please give the other one a try and let me know if the same behavior occurs?

Thanks,
Noris


(wilfred walsh) #4

Noris,

Thanks for your reply. Unfortunately I am about to go travelling for
two weeks, so we will probably have to complete this process after
April 11th. However I will try to answer your questions below.

Thanks for contacting us regarding this issue, I’d be happy to
troubleshoot with you here. I have a few questions starting off:

  • Can you please confirm if you are using the Devialet Air or
    Devialet RAAT protocol to stream to the endpoint?

I set the devialet source to be “roon ready” using the source selector
on the devialet amp. Once it starts operating though, it appears to switch
to AIR. This puzzles me a bit as I think I have not explicitly enabled AIR in
the roon software: under Settings-Audio I have enabled Devialet
Networked only, and Airplay is not enabled.

Should I be doing something else?

  • What is the model/manufacturer of your switch?

My router/switch is:

NetComm/Wireless
VDSL2/ADSL2+ Dual band AC1600 Gigabit gateway NF18ACV

and there is also a second switch in the ethernet path:

TP link TL-SF1008D

However I am pretty sure the hardware is not the problem as some days,
like today, the system works perfectly and as far as I am aware,
nothing has changed since the last time I had the problem!

  • Have you tried rebooting the Core, Networking gear and endpoint
    yet? I would give this a try.

Yes of course, several times and in all possible sequences. I check that the CPU, disk and network of the NAS are not busy doing other things, as surely the problem is that somehow the NAS cannot deliver the data quickly enough to either the roon core on the NAS or from the core to the devialet? ie I review the NAS resource monitors and also run the linux “top” program on the NAS to look for disk/cpu/network intensive processes and check that there are none.

  • I noticed that your QNAP NAS model has two Ethernet ports, can you
    please give the other one a try and let me know if the same behavior
    occurs?

In fact it has four. I will try them all, but doubt this is the issue

  • as I said sometimes it works perfectly so my guess is a software
    issue rather than a hardware issue.

In the forums somewhere I read that other people who have had this
apparently common problem claimed that the upstream ISP might be doing
something that interferes. If this is the case can you please let me
know what should I tell my ISP about what I require them to do or not
do to keep Roon working. The ISP is quite approachable and willing to
make changes.

My suspicion is that a larger buffer might solve such problems - I see
one buffer option in roon where I have set it to the 5000ms maximum -
perhaps larger buffer options would be helpful?

Thanks for your further ideas, I feel a permanent understanding/fix of
this problem is essential.

W

PS I also note that the roon app on windows 10 works well, I use that
mostly. But the roon app on my android phone (running 5.1 baseband
20234) is hard to use as random letters are missing in the menus.


(Noris) #5

Hello @wilfred_walsh,

Thanks for letting me know that info. Are you sure that you have the RAAT zone enabled and selected in your Roon App? I would use these instructions to check if you are using Devialet Air as the Air and RAAT output are two different things and have to be configured separately in the Roon App.

I have previously seen reports that Devialet 440 devices behave better when the network interface is using a 100Mbps connection instead of a Gigabit connection. From the documentation I found regarding your QNAP, at least one of the ports on it should be 100Mbps, so finding this port and giving it a try will be a useful troubleshooting step.

Some screenshots of your Roon Settings -> Audio tab would be appreciated to diagnose the issue further. You can use these instructions to upload screenshots to this Community website.

Can you please open a separate support ticket regarding the Android issue and attach a few screenshots of what you are seeing?

I hope you have safe travels and I look forward to your response when you are back!

Thanks,
Noris