Intermittent ARC Connectivity Issues under Stable Connectivity Conditions

I too am in the North Bay Area of California and ARC doesnt work consistently for a about 2 days every couoke of weeks or so. My daily commute is exactly the same every day. So its not my Verizon connection to blame. ARC works perfectly fine all the other days. It tells me I have a poor connection, which I clearly do not. What can I do to improve ARC reliability?

Hi @audiom3,

I hope you don’t mind - the tech support team has moved your post into a dedicated thread where we can investigate directly.

Would you mind elaborating on your Core setup and network infrastructure? Specifically, point us towards this information:

Thank you for reaching out for assistance with port forwarding. I’ve split your post into a separate thread so the team and other users can assist you more directly.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

  6. Are there any specific error codes displayed in the Roon Settings → Roon ARC tab when you see these connectivity messages in ARC? Try disabling WiFi on the phone when at home to see if you can reproduce the symptoms (at your convenience).


Hi Connor. Thank you for moving this to its own post. Sorry for the delay but I wanted to see if uninstalling and then reinstalling the ARC app would remedy my issue first but it didnt help. I’ll go through these steps next and answer all of your questions soon! Thanks again.

Hi Connor. I have manually enabled port forwarding since reading the help guide. But it is strange because I tried manual port forwarding when ARC was first released but then disabled it as it didn’t change anything at the time. I did the same for Plex and all is great with Plex and Plexamp though. I will see if that fixes the issue moving forward. But just in case…

  1. Sonic 1G fiber internet
  2. ASUS RT-AX89X router and their fiber ONT
  3. unmanaged Mikrotik CRS309 fiber switch
  4. Zero
  5. Intel NUC i10 running ROCK software. It is connected thru the mikrotik and then out thru the router. It comes out of the NUC as copper and quickly gets converted to fiber but I know what I’m doing there, so that definitely isn’t any cause for concern, only a better listening experience :slight_smile:
  6. It was saying ‘not ready’ before enabling manual port forwarding but now it shows ‘Ready’ under settings.

Thanks for your help!

Hi @audiom3,

Please accept our apologies for the unexcusable delay in responding after you provided your technical details.

Reviewing routine diagnostics from ARC, the tech support team is seeing strong evidence of poor performance due to a number of reported factors in logs:

  1. Memory and storage pressure on the ARC device. Are you nearly out of storage on this iPhone? Are you running any other apps simultaneously that draw significant RAM?

  2. There are warnings suggesting a build mismatch or other authentication failure between Roon Core, Roon Remote, and ARC. I recommend verifying you’re on the latest and most recent build on all devices for each app. It might be best to uninstall and reinstall ARC to verify you’ve cleared any cached data from a previous build.

  3. Playback errors. These appear in many cases to result from timeouts on the local network.
    Does this phone have strong WiFi signal when you’re using ARC? Is it on a different subnet than your router?

  4. Are you experiencing any issues with port forwarding? Since recent diagnostics are all on network for ARC, we want to confirm that manual port forwarding continues to function for on-the-go playback. Please let us know if you’re experiencing any issues with port forwarding at this point, and paste any diagnostics available.

We’ll keep a close eye out for your response. Thank you again for your patience!

Hi @audiom3,

Did you have a chance to review my previous message? We’ll keep this thread open for a few more weeks, just in case.

Sorry @connor Ive been away on business. I’ll reply shortly to all of your questions. Thank you for the great support!

Hi @connor. Thanks again for all your support. I will do my best with all of your questions.

  1. No, I have used under 50% of my phone’s storage and I keep apps from running in the background. I am definitely a bit anal about this. I often accidently kill ARC because I do this while listening on the road (not driving, I promise). My Intel NUC 10 is over-kill as well. I assembled mine with 16GB of RAM.
  2. When I arrived home from my business trip, I noticed I had an update pending. I went ahead and installed all and then removed/reinstalled ARC from my Android phone. This may explain your noted mis-match? I don’t know…
  3. I don’t fully understand your question. My phone is on the same subnet while at home (where my Intel NUC 10 is located) but while on the road, I assume no, since I am on the Verizon network. And naturally, I only use ARC while out on the road. Did I mis-interpret your question or give bad info?
  4. Port-forwarding is working fine. I check via my Samsung Tablet every now and then to make sure ARC remains fully access-able outside my LAN.

A few comments since posting the initial issue and enabling manual port forwarding…
a. My album artwork does not display. I can exit ARC and then close it completely on my phone, then open again and it loads for about a song. Then ARC either pauses the current song for 1-2 seconds and loses the artwork or it just vanishes between songs.
b. Same issue with album name. It displays as ‘Unknown’ now. Song title and band info are reporting correctly. THIS ISSUE JUST STARTED THE OTHER DAY (right after I returned home from my business trip and since doing the latest Roon update). I am sure that’s an important detail that you should know.
c. There was only one time since my initial post where ARC was behaving erratically. I would start Roon Radio and after one song, it would display ‘nothing currently playing’ at the bottom of the ARC screen (on my phone app). This was exactly the issue before setting manual port forwarding, except I could not play another song after it stopped. But this time, I was able to select another song or radio and it would start up just fine. I went though this 3-4 songs then just closed ARC and started up Tidal which worked perfectly fine. The next day, this seems to have resolved itself. I do not recall doing an update from my Samsung Tablet that evening. Let me know if you need anything else! Thanks again.