Intermittently unable to connect from iphone / ipad / pc to Linux Core

I am running a roon-server un my Linux server.
My Clients are Ipads, Iphones and my PC.

From time to time i am unable to connect to my Roon server.

I have 1 network at home. My server has a static IP adresse:

and my clients get dynamic ip’s in the same range.

Even if i choose the option to input the ip directly they can’t seem to connect to the core.

What can i do to “troubleshoot”. Are there any logs on my server that i can access?

br Ronni

Flagging @support for this and changing the topic so that the Linux gurus can maybe help.

@Tech_Whisky_Lab maybe Fernando who has a UX history might know a thing to look at too :stuck_out_tongue:

@Ronni_Hostrup Perhaps some more info on the network topology and also the Linux version etc in use.

Logs are at /var/roon/RoonServer/Logs and /var/roon/RAATServer/Logs. Good luck. :slight_smile:

As @wizardofoz said, more info about network and server would help. Any firewall involved? Wifi extenders, Powerline adapters?

Hi All!

My server is: Ubuntu 16.04.2 LTS

My network is quite simple:

Server connected through lan
Clients connect through wifi.

The router acts as DHCP server.
there is no firewall in play.

I have 1 router + 2 extenders acting as accesspoint.
ie. connected by rj45 cable and exposing the same SSID as the “main” router.

Sometimes it’s only the phone that can’t connect, other times its my laptop, or both.

i haven’t been able to locate any logs - to see if their might be some connection atttemps on the server.

Br Ronni

Just for testing, can you try to disconnect the extenders and connect directly to the router with your Phone? Also – can you hook up the laptop to the router with a network cable instead of using wireless?

I know these are not permanent solutions, but it may help the elimination process.

Hi Again!
Thanks for info with the logs…

i can see that when i connect it writes this to the logs:

05/26 12:46:13 Info: [stats] 2616mb Virtual, 533mb Physical, 199mb Managed, 0 Handles, 40 Threads
05/26 12:46:17 Warn: Error in web request NetworkError (The remote server returned an error: (502) Bad Gateway.)
05/26 12:46:17 Trace: [push] request to manager failed
05/26 12:46:17 Trace: [push] retrying connection in 3290420ms
05/26 12:46:28 Info: [stats] 2616mb Virtual, 533mb Physical, 199mb Managed, 0 Handles, 40 Threads

But right now it works off-course :).

I will try the direct cable approach. next time.
And yes - i can determine which AP i choose. No problem.

I will have to wait until next time that the connections does not work - and then see what the logs says.

br Ronni

Those logs are a red herring – you can safely ignore them (it’s known to Roon and harmless).

Im stabbing in the dark but Jumbo frames has always caused issues - at least in the past if its seen as active I recall there was some funky stuff happening so if you have that turned on then try turning it off.

Managed switches have had some negative press too…tho my Unifi setup seems to chug along nicely.

DHCP is all a single source/server and I assume its also giving the correct DNS to all connections. No wifi guest networks that are not getting access to the main network devices?

Hi @Ronni_Hostrup ---- Thank you for the report and sharing your observations with us. The insight is appreciated!

A lot of good advice has been offered here by both @wizardofoz and @RBM (:clap:) . I know you are in a bit of a holding pattern as the issue has not manifested itself again, but if it does I would strongly recommend the following (just to reiterate on what others have advised):

  • Test with your laptop connected via ethernet directly to your router.

  • Bypass the extenders (temporarily of course) and see if your remote connections are more stable with this configuration.

  • From your report I know you’ve mentioned that there are no firewalls in play, can you confirm that there are no active antivirus applications as well.


Hi Again!

I can now recreate the error.

As you can see - the “server” sees the client - but somehow can’t connect it.

Input is apreciated!

br Ronni

Hi @Ronni_Hostrup ---- Good to hear from you again, thank you for the update.

The last we spoke, a handful of troubleshooting tips were provide not only by me but also but the other users in this thread. Can you let us know what you’ve tried and the results of the tests performed, so we have a better sense of where to go next?