Internet Radio Fails to Play

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Verizon WiFi / Google Mesh Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Peachtree Audio Deepblue 2

Description Of Issue

I’ve tried Roon Internet Radio from time to time, but have never been able to make it work. When I paste in a URL and then launch the station, I get this error:

I tried this with a few internet stations, but get the same results.

Please share the URL you posted into Roon. Thanks.

I think it was:

I also tried WRTI’s direct URL

Just pasted it in and works fine

I can play this fine, so the URL seems to be correct.

Hi @David_Weinberg,

Does this same behavior occur if you play to System Output of a remote device?

Can you confirm how your Core machine is connected to the network?


I rebooted Roon and tried again from my iPhone (is that what you mean by system output?). Same results. I captured my steps in the linked video clip:

Thanks for giving that a try, @David_Weinberg.

Are you able to play other content okay, local/TIDAL/Qobuz?

Have you tried using any other Internet Radio stations and confirmed if the same behavior occurs?


I don’t subscribe to TIDAL or Qobuz. My local files (stored on my NAS) perform well without issue.

I also tried adding KCRW following the link embedded in the knowledge base internet radio page. Same result.

Finally, I should state that my ROCK hardware is an underpowered Intel NUC (6CAYH). That notwithstanding, Roon performs well with that NUC with other sources outside of Roon Internet Radio.

Thanks for the details here, @David_Weinberg.

Since this station appears to be working for others, the issue is likely stemming from either a performance issue from the Core or a networking issue.

Can you confirm how the Core is connected to the network?

Do you have another device that you can temporarily use as a Core? Does the same behavior occur in that configuration?

My Core is connected to my network via Ethernet cables from the NUC to the NAS.

I was able to move my Core to a Windows 10 computer (first time doing that : ) and Internet Radio started right up.

So does that mean that Roon playing NAS-based music works fine on my underpowered NUC but Internet Radio does not?

Hi @David_Weinberg,

Since things are working on the Windows 10 PC but not on the NUC Core, yes, it is likely that the under-powered Core is not up to the task.

One thing to check, though, is if there is any difference in how the Win10 Core is connected compared to the NUC. Are they both connected to the network in the same way?

Just to verify, are you saying the NUC is connected directly to the NAS? If so, can you try connecting it directly to the primary router instead? Is there any change when doing so?

Win10 is WiFi and the NUC is Ethernet. Kind of counterintuitive as you would think Ethernet has greater bandwidth.

Hi @David_Weinberg,

Yes, we always recommend that the Core is connected via Ethernet, so most likely that’s not the case then here. Can you confirm what device the Core is connected to via Ethernet? Is it a router or the NAS?

The Core is connected to the router via a switch. The NAS is also connected to same. I created the image below sometime ago so I could make sense of my network (much trouble back in my JRiver days).

Thanks for confirming, @David_Weinberg.

As mentioned above, this is most likely a performance issue since things are working with your Windows device. It may be worthwhile to try connecting the Core directly to the router, bypassing the switch, to see if there is any change. If that doesn’t work, though, it’s probably that your Core isn’t up to the task of internet radio playback.


After some delay, I decided to upgrade my old 5CPYH NUC. I finished installing Rock on a NUC8i7BEH. Roon works fine on the new NUC, but I am getting the same results with Roon radio - I get the following when trying to start to stream a station: “Playback was interrupted because a track failed to load”.

I thought the new NUC would take care of it. Not so. What to do?

Did you install the codec pack on the nuc?

I did and that took care of it. Thanks.

As background, I had trouble installing the codec on the old NUC (and revisited those struggles yesterday). In one of my first posts here at Roon Community, I was advised that I did not necessarily need the codec pack loaded since I was using FLAC files. But since that time, and with the introduction of internet Radio, the codec is clearly needed. After installing the codec and rebooting, the radio feature now works- thanks again!

One tip for Roon- the codec kb is okay, but less than clear. I was only able to complete this task after looking at this Audiophile Style video.

Yes the flag thing was weird. I was a bit doubtful of the suggestion to be honest.