Internet Radio Keeps stopping

So, I’ve been really enjoying the internet radio, especially the FLAC stations, however, it only seems to be very brief.

After 2-3 minutes of play, it has started to stop and then has trouble finding it again.

My Setup

NUCi5 core on Windows 10.
Raspberry Pi endpoint running Volumio into a Project Pre Box S2 DAC.
Also running direct on Windows 10 in the office.

This has happened both over Ethernet (via power-line adapter) and via Fios Gateway WiFi on 5GHz.

Tidal and local files seem to run flawlessly.

I am up sampling when listening to non-MQA files, however, I turned that on and off without any improvement.

I removed DSP control completely, with just volume leveling on.

The stations that I am listening to include the FLAC stream of Absolute Radio from the UK, various BBC streams and some local streams here in Pittsburgh like WYEP and 100.7 Star.

I have tried capturing the moment that it stops on a screen shot, though I’m having trouble uploading pictures at the moment. I have not caught it yet, but it appears that my processing speed drops very low right at the point that it disappears - Does it take more processing to work with a radio stream than a stream from Tidal?

Thanks for the report, @bevan_court!

Also running direct on Windows 10 in the office.

Just to confirm, is this the Core machine that you played to? If not, can you try playing directly to the System Output of the Core machine and see if you experience the same behavior?

Are you doing any upsampling?

If you play non-FLAC radio stations do you still see this happen?


I’m having the same issue whether I play it on to core or the raspberry pi.

It happens with upsampling and when i turned it off.

Thank you for the update, @bevan_court.

May I ask that you please verify the following:

  • What model NUC are you using as your Core?
  • Can you confirm that non-FLAC stations are playing just fine?
  • If you connect the Core to your router directly (bypassing power-line adapter) do you still experience this behavior?
  • What is your experience like playing these stations outside of Roon?


Hi Dylan

I’ve not had time to add the NUC and play directly, I’ll try that later.

I’m using an NUC7i5. 7260 running at 2.2GHz with 8GB RAM

I’m having the same issue on non-FLAC stations

Stations play fine outside of Roon.

I did do one thing in Roon that helped somewhat.

One thing that I have seen is that the processing speed starts high and gradually drops down until it hits 1.3. Once it drops below that level, it appears to drop the signal.

When I’m playing something from Tidal, the processing speed is much higher:


I tried connecting the core directly, it still has issues and then I tried it with all volume leveling and upsampling off, purple lights indicating bit perfect. It still drops out after 3-5 minutes.

Thanks for the update, @bevan_court.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


I started absolute radio today at 7.15 est. It stopped playing at 7.18

I then tried a few other stations and they seemed to work ok.

Thanks, @bevan_court! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


I have exactly the same issues with Absolute Radio Flac streams. They stop after a few minutes?

Hey @bevan_court and @adm95,

I wanted to reach out and let you know that our tech team is currently investigating this behavior. I’ll be sure to update this thread as soon as I receive more information from the team.

Thank you,

1 Like

Thanks Dylan - any ETA when team will have looked into this? Can you see the issue ala Roon?

A wondering if there was any news on this?

Problem persist… Internet radio almost unusable.

I’ve still been having the same issue

1 Like

Just experimenting here and it seems radio stream doesn’t stop when upsampling is off. Sound is time to time interrupted, but after a second plays on.

Hey @bevan_court & @Pavel_Tesar,

I checked with the team on this, and we currently have a ticket open with the development team to track the behavior that’s been reported here. I cannot give any specific timeframes at the moment, but I can promise you that as new information becomes available I will let you all know here.

Thank you,

I do find it still stops on FLAC stations as well and even volume levelling can cause it to stop

@support I too am having this issue but I have managed to play Absolute Radio (70’s) for more than an hour before it stops. I only use a SonicTransporter i7/HQPe setup. I have a wired gigabit connection with music on a separate switch. I have no issues with Tidal or local files playback. I have tried connecting the ultraRendu to the switch and the i7 but there is no difference. I emailed @agillis today since I wasn’t sure where the problem lies as he has always been so kind to help figure out an issue. I am glad to have been directed to this thread and will be glad to help get this resolved :wink:


I did raised this issue in another thread

Roon doesn’t have an auto-retry feature when the internet stream is interrupted and will stop. Most software like JRiver already have this feature baked in long time ago.

Basically it is useless to play internet radio in Roon if one experience this kind of interruption. So until they add the auto retry feature you have to keep pressing the playback button if you don’t mind doing that.

1 Like