Internet Radio - Transport: failed to load media [Solved - Updated QNAP and FFMPEG]

I have previously added internet radio stations to Roon, but most of these, including all the BBC stations e.g.
which worked previously now come up with the error “Transport: Failed to load media”.
If I try adding them again I get the message “Roon could not find a radio station at this URL”.

One or two still work, has something changed?

I loaded that link and it worked OK.

Hello @Graham_Ball,

I cannot load that link you posted, neither in Roon nor in VLC. Is it possible that the radio station is offline or has changed the URL of the stream? I would double check the location you found that stream to see if they have additional links and test those as well.


@noris I have just loaded it and it works perfectly, could it be it’s a U.K. only channel?

@Ratbert – You seem to be correct, I have just loaded up my VPN and switched to a UK based location and I can play the file fine but I cannot play it when using my USA IP address.

@Graham_Ball - I would double check to see if this stream is available in your current location as it seems to be restricted to specific countries.


Thanks for the suggestions. I am in the UK, so it should be OK.
The problem seems to be with aac and mp3 formats which Roon supports through the operating system, FLAC formats are working. I am using Roon core on my QNAP NAS.

Hello @Graham_Ball,

Is it possible that the Radio station is not available in your specific city in the UK? I have tried it using a London based IP address but if you live in a smaller city maybe it’s reserved just for larger cities now?

I have also gone ahead and enabled diagnostics mode for your account, what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded for further analysis. Please try playing the track once again and note the exact local time in your country that you play it at and I can check to see if there are more detailed explanations for why it does not play in the logs. Please let me know when possible.


I’d be checking if ffmpeg is on the Qnap and what version.


I’m not an expert in this but when I type in ffmpeg at the NAS command prompt I get version 0.8.10.




Just tried playing internet radio - only FLAC working.
Finished 15:00 UK time.



That version of ffmpeg is ancient. I would look to update it if at all possible. I hope I am not stepping on your toes Noris!

@Graham_Ball - Thanks for testing that and confirming only FLAC works.

@Henry_McLeod - You’re not stepping on any toes, rest assured, I’m actually pretty glad that you brought up the ffmpeg version question as it would have not been one of my initial guesses.

That version of ffmpeg is pretty old and it likely the factor causing the issue, thanks for pointing that out. I have to double check with the dev team on their suggested course of action is and will let you know once I have a reply on next steps forward.


Hey @Graham_Ball – just wanted to let you know we’re looking into this. The issue is related to how the newest version of Roon handles older versions of ffmpeg, and we are working on a fix that will address this problem.

For the moment, I don’t have a firm timeframe on when that fix will go live, but we’re working to ship it as soon as possible. In the meantime, I’d recommend trying to update ffmpeg on the QNAP if possible (any ideas @crieke?), or running your Core somewhere else temporarily.

Our apologies for the trouble here. @noris or I will be in touch soon.

Hi @Graham_Ball
can you specify which QTS operating system you have installed on your QNAP and what model you are using?

Hi @crieke
I have the TVS-471-i3, currently running QTS version 4.2.3.

Many thanks,


Thanks for the info.
Are there specific reasons to not having installed the current QNAP 4.3.x version?
Just asking as the ffmpeg version there will be already bumped to 3.3.6…

No particular reason, the QNAP just runs in the background.
I have now upgraded to 4.3.4 and internet radio is working again!
Many thanks for the excellent support.


If there is no reason to stay on QTS 4.2 I’d highly recommend to update to the current version.
Please let me know if it changes anything to your current internet radio situation.

Hello @Graham_Ball & @crieke,

Glad to hear that updating the QNAP to the latest version has resolved this issue! Thanks again for your valuable feedback here @crieke!

@Graham_Ball, if you run into any other issues please feel free to let us know. Since the original issue seems to be resolved, I am marking this thread as [Solved] but if this is not the case please feel free to reach out and let me know, otherwise wish you all a great day!


Just a bit of feedback: RPMFusion and other repos for RHEL/CentOS are still on the ffmpeg 2.8.x long-term-support train. In your testing, I’d strongly suggest testing against 2.8.x to ensure things work as you expect, as this will be a commonly installed version.