iOS Devices Intermittent Connection to Roon Core

Roon Core Machine

Mac Mini (Late 2012) 2.5 GHz Dual-Core Intel Core i5, 16 GB 1600 MHz DDR3
MacOS Catalina 10.15.7 (up to date)
Streaming to HQPlayer 4 Desktop 4.19.0

Networking Gear & Setup Details

Core switch - NETGEAR 16-Port Gigabit Ethernet Smart Managed Pro Switch with various other un-managed Gigigabit network switches.

WiFi is provided by three TP-Link AC1350 Wi-Fi Dual Band Gigabit Ceiling Mount Access Points.

Roon Core (Mac Mini) and PI2AES streamer are connected to the network via Ethernet.

Connected Audio Devices

Raspberry Pi-based PI2AES Streamer running RoPieeeXL Configured as HQPlayer NAA

Roon Remotes all connect wirelessly

iPhone XR
iPad mini 4
MacBook Pro 13

Number of Tracks in Library

Not many - Use mainly Qobuz

Description of Issue

iOS devices iPhone and iPad connect to the core intermittently. This has not always been the case - they used to work fine but more recently there has been a problem. The Macbook Pro always connects without any problem.

When I open Roon on the iPhone or iPad it usually fails to connect - If I select the option to connect to a different core, it shows a red dot ‘Connecting’. Once I get a connection - which can take many minutes, then the connection can drop at any time. Music will continue to play after the connection drops.

I have tried re-installing the app on the iPhone without any luck. I have tried closing every other app on the phone - That has made no difference either. I can’t think of anything else to try.

That would be correct and expected behavior.

As a test, next time you disconnect, you should get a screen with a blue HELP link. This will take you to a pop up that lets you input the IP of your server. Enter and see if that connects, and stays connected.

I find this may happen if the Roon Remote app has been “put to sleep” by iOS . Physically closing the app and restarting fixes.

I a not sure of the technical reasons but once you have started a stream , the app goes dormant , and iOS deactivates it until the next time you try to select a new stream.

I vaguely recall @danny explaining this some time back.

Hi Mike, thanks for the reply.

Unfortunately, I don’t think that’s the problem, I have found that closing the app and re-opening it makes no difference, it still won’t connect.


I followed the Help link - but I didn’t get a popup - I just get an option to select a different core. The page says 'Remote connection waiting for remote Core

Hi @David_Troughton,

Thank you for reporting this issue.

I’ve attempted to enable remote diagnostics on your core but am not getting a response. Oddly, it’s showing that it’s online but doesn’t respond to me.

This along with the “waiting for core” errors you’re seeing might be telling. One theory I have is that perhaps some of the sleep features have changed on the Mac. Can you double-check all of these settings for us? It almost sounds like the network is there but the hard drive is going to sleep. Just an idea of something you can look at. Let me know if you find a potential culprit in the sleep settings and if so; the next part might be irrelevant.

Either way, we need to take a look at the logs. So we can move forward, I was hoping, for now, you could use the directions found here and send us over a set of logs using a shared Dropbox link.


This is an older mac…does it have an SSD boot drive internally?

What else is running on the Mini?

what else is using the wifi…ie how many devices and are any high usage systems like gaming or video streaming (TV or zoom calls etc) running at the time?

Hi Wes

I have uploaded logs for you - 2 sets - The second set was extracted after the server was brought down (I didn’t read the instructions properly until I had already sent the file).

I took a look at the sleep options - Computer Sleep was set to never but the Put hard disks to sleep when possible was checked. This is now unchecked. However, a quick check has shown no difference.

I don’t actually think it has anything to do with sleep because:

My MacBook Pro connects every time without a problem,
When I do get a connection from one of my iOS devices it doesn’t mean the other will connect. Just now my iPhone did connect but my iPad wouldn’t. At that point, the MacBook was connected as well.

Hoping the logs reveal something.

Thanks, David


Agreed, it is an old Mac.

I upgraded the HDD to an SSD some years ago and added 16GB RAM. I only use the mini it for Roon and HQPlayer. I connect to the machine with Chrome Remote Desktop.

We are not heavy users of Wifi. We have SkyQ for TV (which sometimes streams from the Internet and between boxes over the local network) but all the boxes are connected via Ethernet. The MacBook connects wirelessly to the Roon Core over wifi without any problem.

Well let’s see what roon support can come up with.

1 Like

Hi @David_Troughton,

Thank you for your uploads. Oddly, as you went to do this, the request for diagnostics finally came through. This tells me that there’s something on the core or the connectivity that the core has is going to sleep

In looking at the logging I see a whole host of connection timeouts and failures. This is occurring between your iPhone and core as well as your Macbook Pro and core. There are recoveries of the connection as well which would explain why the issue seems to happen intermittently.

Here’s an example without providing any internal address information:

08/29 19:45:16 Trace: [rnet/RnetJsonClient] no data received for >10000ms. Killing connection.
08/29 19:45:16 Warn: [rnet/RnetJsonClient] error writing to connection
8/29 20:41:08 Trace: [raatserver] [RaatServer MacBook-Pro-2 @ 192.168.x.x:9200] client connection failed. Retrying in 500ms

There are so many possibilities with these timeouts but the main theme is that your core is losing connection to wireless devices on the network and at the same time; the core is inaccessible to Roon’s systems.

Can you see if you can duplicate this behavior by bypassing your switch?


Thanks Wes, Very interesting. If the problem is not confined to the iOS devices then that puts a whole new complexion on the problem. I have another switch I can substitute and I can look to see if there is another device on the network that might be causing a problem.

Interesting that iOS devices are more susceptible to the issue than other devices on the network. Thinking about it, this might explain other glitches I see occasionally.


Hi Wes

Just to let you know this issue is now resolved. The problem was the RouterBoard hEX broadband router on the network. I replaced it with an alternative router I had and the problem went away.

Thanks for the diagnostics, it really helped.

1 Like

Maybe mark as The Solution, tick etc


That’s music to my ears!

Enjoy the music on your side and don’t hesitate to reach out if you have issues in the future.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.