IOS remotes can't find Roon core, v1.5 Build 320

Hi, guys,

I updated to Roon 1.5 Build 320 and my IOS devices now are unable to find the remote core. The IOS client first says that the new version requires a database update that may take longer than usual. Then, after 10 minutes or so, it says it can’t find the core. “Waiting for remote core” is the message. It appears to me that the core disappears from the network because I can’t connect to it via the web browser either. I’ve rebooted multiple times with the same result.

Roon sever runs on an Intel NUC i7. The NUC streams music from a NAS as well as Tidal to apple devices running the latest OSX and IOS versions as well as Roon 1.5 Build 320.

When I reboot the NUC, I am able to connect to it via a web browser to the IP address, but within a few minutes, the Core becomes unresponsive, as though it has disappeared from the network.

Other network devices still work fine. I can connect to the NAS remotely without difficulty. I tried changing out the ethernet cable and even installed a different router. I’ve rebooted all the devices numerous times. I also tried reinstalling roon on the iPad Mini I use most often as the client, but it made no difference at all. I also tried running Roon on a Mac Mini with exactly the same results.

Thanks in advance for your help!


I’ve observed similar behaviour too. Sometimes iPhone or iPad and sometimes my MacBook Pro. Rebooting had no effect; eventually reconnects.

Running Core on Ubuntu 18.04.

Hi @David_Carlson ----- Thank you for the report and sorry to hear of the troubles with the mentioned IOS devices acting as remotes.

Moving forward, to help us understand why you could be experiencing this behavior may I very kindly ask you for the following:

  • Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.

  • Please verify the models of the iOS remotes you are currently using.

  • Do you by chance have another devices that you can setup as a Roon remote that has the capability for both a Wifi or hardwired connection to you network? Just curious how a hardwired connection responds.

  • I understand that you have tried reinstalling Roon on the remote devices, have you tried performing the same with ROCK via the web UI?



Sorry for the slow response, Eric. We are in the midst of a plumbing emergency at my house. I’m happy to provide any information you need,

I tried reinstalling the Rock operating system on the NUC with no change in the issue.

The network consists of a cable modem attached to an Airport Extreme II. There is Gig ethernet over powerlines as well as 80211n wireless. The wireless network is extended via another 80211n Airport device. The primary remote is an iPad Mini II running IOS 11.3.1. I also use my iPhone X running IOS 11.3.1 as a remote. A Mac Mini running RoonBridge is the interface between the networked NUC and my Mytek DSD-192 DAC.

As for a hard-wired remote, I have that Mac Mini that is connected via ethernet over powerlines, and it has the same issue. When I fire up Roon, it says "Choose your Roon Core and is unable to find it on the network.

I could try setting up a Roon Core on the Mac Mini as it also is connected to the NAS that holds the music library. (It still is able to play music via iTunes and PureMusic 3, so it seems the issue is likely the
Core on the NUC.)

Thanks again for your help!


Thanks for reaching out to me @David_Carlson, very appreciated! Sorry to hear of the plumbing troubles, I hope that gets sorted out quickly.

Continuing forward, this feels like a networking issue to me especially since you are unable to reach the core via the web UI when the issue occurs, as you mentioned here:

“When I reboot the NUC, I am able to connect to it via a web browser to the IP address, but within a few minutes, the Core becomes unresponsive, as though it has disappeared from the network.”

In my most humble opinion our next move here should be to try and shrink down your network configuration down to the bare minimum and see if the issue presents itself again. I find that when addressing a potential network issue the best course of action is to remove as much complexity as possible from the “chain of communication” and slowly add the links back in to verify where things fail, and where they succeed.

This is a process I have used myself whenever I am trying to diagnose a potential networking issue with my audio setup at home. My “base configuration” always looks the same:

  • I bring any additional networking hardware offline temporarily (APs, switches, etc).

  • I mount my core directly to my router.

  • I use a single remote OR endpoint (depending on the issue)

  • I then try to reproduce the behavior.

  • IF…

    • … It goes away, I begin to expand back out.
    • … It doesn’t go away I now know that the issue is occurring elsewhere.

With the above in mind I would like to have you please verify how your core machine and remote devices perform with a very basic network setup in place, using the example provided above.

Furthermore, you mentioned that you had tested with another router, can you verify the make and model of this device? The reason for my asking is because we have seen issues pop up with the mentioned Apple networking devices in the past and as out CTO Brian points out here, we typically advise against using them.


Hi, Eric,

Sure enough, both of my wireless routers are Airport Extremes, just two different generations. I am back to the newer version now.

I tried removing all other network devices from the router. No change. I then updated the BIOS on the NUC. That was just a few minutes ago, but the behavior appears to be the same.

I noticed something interesting that might provide a clue, though: When Rock boots with DHCP, it says the Web UI address is and then another line immediately appears below the first saying the IP is The Web UI responds at either IP, initially. Within about 15 minutes, the Rock stops responding at either IP. I just tried switching to a static IP of No second line appeared, but it still stopped responding after less than 15 minutes.

I also tried firing up Roon Server on the Mac Mini that is connected directly to my stereo system. It has been working fine for a couple of hours. Everything else is the same – network, NAS, ios remote, etc.



Thanks for getting in touch @David_Carlson and sharing the observations you made while performing the requested troubleshooting exercise. The continued insight is very appreciated!

Continuing forward, can you please verify for me if you have any static IPs set in the Airport Extremes you are making use of? Furthermore, have you tried performing a factory reset on these units since encountering this behavior? I ask because I had an Airport Extreme for testing purposes for a while and every now and I again it would get into a weird state which ultimately had to be cured by performing a factory reset of the unit.


No static IPs. I believe the problem is with the NUC itself. I even bought a new router (linksys) and the issue is the same – the NUC loses its ethernet connection after about 10 minutes and then won’t respond to wifi endpoints or its web page. I’ve opened a support ticket with Intel, and I’ll let you know what they say.



1 Like

Thanks for the update @David_Carlson, I will be on the lookout for your feedback!


Is there a way for me to run a tar.gz file on the Rock? Intel wants me to run a system diagnostic. These are the available downloads (non-Windows):


Hi @David_Carlson ---- Thanks for reaching out to me, I have placed a feedback request with our tech team in regard to your question. As soon as they provide me with some information I will be sure to touch base asap. Your patience is appreciated!