iPad Air w/Roon Remote will not connect with Mac Mini [Solved]

I loaded Roon Remote on my iPad Air and typed in the IP of my Mac Mini and the iPad just keeps searching…

Setup/Background: I have an Apple Airport Extreme 579C-A1354 4th gen Router, running off a Comcast Arris RDK-B Telephony Wireless Gateway Cable Modem TG1682G, with the Arris router turned off so it doesn’t conflict with the Apple router. The firmware on the Apple router has never been updated to the best of my knowledge.
I have an iPad Air (not V2) with a minimum memory setup (16gb).
My Mac Mini is model A1347, a 2010 2.4GHz Intel Core 2 Duo/2 GB DDR3 SDRAM/320 GB HD/SuperDrive/GeForce 320M/AirPort & Bluetooth, upgraded to 8 Gb. It is running just recently upgraded OS X 10.11

I have been able to use my iPad to create a VNC connection to my Mac Mini, so I know the IP address is in the right range. I was able to establish an iPad VNC to Mac Mini connection using the IP address provided on the Mac (under Sharing/Remote Management), with remote management turned on at the Mac Mini. The Mac Mini and iPad are definitely on the same network because i was able to see and control the Mac Mini screen on my iPad using VNC (essentially screen sharing+). There is no VNC software on my Mac Mini.

The Roon software on my Mac Mini correctly displays the computer name, and I have remote connection set to Yes. So all appears to be in order there.

What am I missing? I have tried typing in the IP address about 20 times, and no luck. Do i need to specify a port? If so, how?

Thank you, in advance, for any guidance.


Hi Bill,

This post sets out some troubleshooting suggestions for remote connection issues. It sounds as if you have already confirmed that the remote connection is set to “Yes”. It may be that there are firewalls in the way.

If you can check through the suggested troubleshooting items in the post and if the problem persists we can notify a dev for further investigation and get you hooked up ASAP.


Quick question: does Roon use Mono software for any of its media management?
Specifically mono-sgen?

Bottom line: not sure why, but the lack of connectivity is resolved.

When i booted the mac mini tonight a message appeared asking me if i was willing to accept remote connections from mono-sgen. I recall seeing this message a week or so ago, and I answered NO, because I had no idea what it was, and i was not keen on allowing remote connection to something that was unknown to me. This time I answered yes.

Bingo - minutes later, I started Roon Remote, and lo and behold, it found the connection to my Mini.

Is mono-sgen something that was installed with the new OS X 10.11? Or by Roon? Any idea?
I sure am glad it asked me again, because I would never have remembered that I declined before, because I thought it had no relationship to Roon or remote connectivity Maybe coincidence? I have no idea.

Anyway, once the connection was allowed, Roon took care of the rest, and I have to say, accessing Roon on my Mac Mini through the iPad is implemented very nicely. Nice work.


Hi Bill,

I’m afraid that question is beyond my level of technical competence (a very easily exhausted resource !) but I see that Mono is an open source implementation of Microsoft’s .NET framework and recall Danny saying that Roon is built with .NET (at least in Windows).

I’m pleased you are able to connect now, but if other users are likely to get a similar non-intuitive remote connection request then I’m sure the devs will want to know, so we will leave a notification for @danny and @mike.

Good listening !

Yes, we do, Bill.

Really glad you got this working! Thanks for letting us know and for working through it – we’re going to look into what went wrong here.

We use mono – it is an open .NET runtime. It allows us to program in a manner that the same code can run on multiple platforms. It does not do any media management.

mono-sgen is the runtime that starts .NET programs.

Mike, I am not sure anything really went wrong. My Mac Mini asked me, somewhere around the time I upgraded OS X, and around the time I installed Roon, if I wanted to allow remote connections to mono-sgen. That sounds like reasonably protective action/inquiry by my OS. Of course, having no idea that Roon used Mono, I answered No, I will not allow remote connections. That was the problem. I have the sense that OS X 10.11 asks when to allow the computer to accept remote connections, as one hopes it would. Perhaps simply telling Roon w/ Roon Remote users to ALLOW remote connections to mono-sgen will eliminate the issue. Not sure if it would be easy to override an OS check to the Admin.


We’ve eliminated the mono-sgen name since this issue came up.