iPad Bug - Discography

When using the Roon App on any iPad picking an artist then selecting Discography results in a row of blank album covers and no album can be selected. This does not happen with all artists but is somehow linked to artists where albums from my Qobuz account have been added to the library. I have had this problem for months now so surprised that no one else as reported this bug. This bug appeared since the last couple of updates, PLEASE FIX THIS. This is actually not confined to the ipad App, just tried on the iMac Roon core and the same BUG exists.

Trevor

I’m not seeing that behavior on two iPads. Have you tried deleting the Roon app from your iPad and reinstalling it?

Like I said it also happens on the Roon Core Mac Mini, and yes I have tried deleting the App but the fact the BUG is identical on 2 iPads and the Roon Core would rule out a problem with the App.

The fact that the problem only exists with artists which contain Qobuz added albums to the library is a clear indication that it is without doubt a Roon BUG?

I tried it with Qobuz only added artists/albums and did not get that behavior. I’m not sure we can rule out any potential cause yet. This is with Tidal disabled in Roon and no local albums. These images are my Dell laptop, but I get the same on two iPads. Roon core is on Nucleus.

Now I’m curious… Within your logical framework, what does the fact that the vast majority of users with albums added from Qobuz don’t see this problem indicate?

3 Likes

More likely, this has something to do with your setup. Therefore, please provide details of your Roon setup, as described in the linked post, so Roon support and the community may help you.

1 Like

I have a Roon Core running on a Late 2012 Mac Mini running macOS High Sierra. It has 8GB of 1600 Mhz DDR3 memory and a 2.3Ghz Core i7 CPU. I have noticed since a few updates back that Roon takes a lot longer to load. I have over 2500 albums stored on SSD drives permanently connected to this setup. I have both a wireless network and have a very extensive 1Gbit wired network. I have over 40 years experience of computer systems. I have a large collection of endpoints which work without any problems. The problem I have is present all the time so rebooting or re starting Roon makes no difference and the problem exists on both of my iPad Pro tablets as well as the Roon Core itself.

Hi @Trevor_Slaney,

I would like to take a look at your logs and see what’s going on. Roon hasn’t seen your core online in a few days though. If you could power up your core I will pull logs. Alternatively, I can provide you with instructions to do it manually.

Please let me know either way!

Thanks,
Wes

Sorry for not getting back to you sooner. I am very busy working outside so my need for Roon is very limited, in fact I use a Sonos Roam while I have been working. However having a lifetime subscription to Roon I am keen for it to work when I do use it. My Roon Core is now online and will stay online for a couple of days at least to allow you see what the problem might be.

Regards

Hi Wes,
Have you had a chance to look at my logs yet. I really would like to know why I am having this problem.

Regards, Trevor

Hi @Trevor_Slaney,

I had a chance to look at your logs with our development group and we’re seeing all kinds of connection errors here. There are errors relevant to Qobuz, Roon’s device database, and other services.

Here is an example:

08/12 07:03:29 Warn: [easyhttp] [21] Post https://metadata.roonlabs.net/1/albums/translate?c=qobuz-gb web exception without response: Error: ConnectFailure (Network is unreachable) Network is unreachable
08/12 07:03:29 Warn: [easyhttp] [22] Post https://metadata.roonlabs.net/1/performers/translate?c=qobuz-gb web exception without response: Error: ConnectFailure (Network is unreachable) Network is unreachable
08/12 07:03:29 Warn: [easyhttp] [23] Post https://metadata.roonlabs.net/1/performers/translate?c=qobuz-gb web exception without response: Error: ConnectFailure (Network is unreachable) Network is unreachable
08/12 07:03:29 Trace: [library] endmutation in 29ms
08/12 07:03:29 Warn: [easyhttp] [24] Get https://push-manager.roonlabs.net/1/connect web exception without response: Error: ConnectFailure (Network is unreachable) Network is unreachable
08/12 07:03:29 Debug: GMS: done saving nav stack
08/12 07:03:29 Warn: [push2] request to push manager failed (https://push-manager.roonlabs.net/1/connect) with status code: 999
08/12 07:03:29 Trace: [push2] retrying connection in 142837ms
08/12 07:03:29 Trace: [library] endmutation in 30ms
08/12 07:03:29 Trace: [library] endmutation in 20ms
08/12 07:03:29 Trace: [library] endmutation in 30ms
08/12 07:03:30 Trace: [library] endmutation in 21ms
08/12 07:03:30 Trace: [library] endmutation in 28ms
08/12 07:03:30 Trace: [library] endmutation in 22ms
08/12 07:03:30 Trace: [library] endmutation in 28ms
08/12 07:03:30 Trace: [library] endmutation in 28ms
08/12 07:03:30 Warn: [qobuz] [http] error result from http request: System.Net.WebException: Error: ConnectFailure (Network is unreachable) ---> System.Net.Sockets.SocketException: Network is unreachable
  at System.Net.Sockets.SocketAsyncResult.CheckIfThrowDelayedException () [0x00014] in <5964c1f33a6b4e45985e4259425270a7>:0 
  at System.Net.Sockets.Socket.EndConnect (System.IAsyncResult asyncResult) [0x0002c] in <5964c1f33a6b4e45985e4259425270a7>:0 
  at System.Net.WebConnection+<>c.<Connect>b__16_1 (System.IAsyncResult asyncResult) [0x00006] in <5964c1f33a6b4e45985e4259425270a7>:0```

It looks like we need to look at networking for a potential culprit. Try disabling your firewall to see if it’s the culprit. I might also recommend restarting your router and core. If you are utilizing network switches restart those as well. I highly recommend eliminating any type of managed switches from the equation as well.

Unfortunately, there’s no specific solution but we know that networking is at the very heart of the issue since we see so many connection errors and services failing to connect.

Thanks,
Wes

1 Like

Hi and thank you for looking at my logs. It is quite disturbing to soo so many errors. I do have a VERY large network with standard 1gbit network switches and the Roon core goes through 3 switches before connecting straight to my German Fritzbox 7390 router which then connects to my Virgin Media box. The Roon core is restarted every time I restart my MacMini and my network switches are powered down overnight so they too are reset every day. I have just reset the router and Virgin box (router in modem mode). I have also tried with the Roon core connecting to the router via WiFi only. The firewall in the MacMini is turned off. I regularly do a broadband speed test to ensure all is ok. What more can I do as none of what you suggest fixes the problems ?

@Trevor_Slaney,

Unfortunately, it’s not an easy task to narrow this down. We seem to be finding connectivity errors in multiple elements of Roon function and no specific root cause other than a general “it’s a networking issue” type of talk in logging.

I had an issue with a McIntosh RS250 at one point that required this. It was located in my basement and connected to a switch that was connected to a network drop in the room. My troubleshooting path was to first connect the speaker directly to the router and it worked just fine. This meant hauling the giant speaker upstairs of course! Then I connected it directly to my network drop and it worked fine (should’ve done this first!). After that, it was a matter of trying every port on my 5 port unmanaged switch and when I did; found that only two ports worked at all. Not sure why (surge, bad HW, or cheap TP Link HW) but that’s how I narrowed down my scope.

In your case, if your core is connected directly to the router and the issue goes away, we know it’s something in between choking out the path.

Thanks,
Wes

Further to my last post I have connected the Roon core straight into the router and it made no difference. I then tried a simple experiment, for the artist Prince Royce I completely removed all traces of the Qobuz albums. This immediately fixed the problem. I then added some Qubuz albums for that artist and the problem did not reappear so it looks like I have found my solution. While it is clear that something is not quite right with my network the fact that connecting my core straight to the router eliminated any network problems and even more to the point removing the Qobuz albums to me is a clear indication that something must be amiss within Roon ? I would also note that having checked a lot of artists I only actually came across 2 with the problem, and coincidentally both being Latin American/Spanish singers, Prince Royce and Marc Anthony. I will monitor the situation but for now at least I think I have found the solution. Thank you for your assistance, Trevor