iPad can no longer connect to Roon Labs Nucleus

Core Machine (Operating system/System info/Roon build number)

Nucleus running OS 1.0 (build 227) and Roon Server Software 1.7 (build 710)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Comcast XF AB72 and NETGEAR 8-Port Gigabit Ethernet Smart Managed Plus Switch (GSS108E), Cat 6 cable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB Wyred for Sound DAQ

Description Of Issue

iPad can no longer connect to Roon Nucleus, but this worked fine for a year until 2 days ago.
When starting Roon, a Roon login page appears, and when logging in with my credentials (and after a very (very) long wait/logging in attempt) the following error message appears: " Network error; Please check …" When checked all devices can be pinged (reached) at their respective addresses.

Hi Edgar,

Welcome to the community.

By any chance, do you see the option to Unauthorize your Roon Core? If so, select it and that should allow you to connect again.

Cheers, Greg

where should I be seen this option.

I believe you should see it on the log in page. If not, it could be another issue.

Hi @Edgar_Meyhofer,

Welcome to the forum! Can you please share a screenshot of your Nucleus Web UI tab that has the Network details visibe? Is there any change in behavior if you reboot your Nucleus and your network?


please find attached a screenshot.

I used a Window (Win10) machine to get to the web ui.

Also, rebooting all devices makes no difference. Furthermore, I reinstalled the operating system, which made no difference.

To get there (login in) I had to use the following steps:

  1. Roon Login

  2. Go back to connect to Roon

  3. Are you online Retry

  4. Add your music

  5. Add Music Service

  6. Set up your audio device

I never had to do all these steps in the past.

Thanks for your help.



Hi @Edgar_Meyhofer,

Thanks for sharing that screenshot! I see here that you are using Comcast DNS of in your DNS field.

We have had a few reports that this DNS server is unreliable, so we suggest changing your router’s DNS servers to Cloudflare DNS, Quad9 or Google DNS.

Can you please make this change and let us know if it helps with the login issue?


Do I need to switch to Static IP to do this. I read that Roon (in general) recommends DHCP and that does setup up Comcast adress as DNS server.

When I ping the Nucleus IP address ( the Nucleus replies within <1 ms.

Please advise.

Thank you,

Hello @Edgar_Meyhofer,

DNS changes are best suited on a router-level, is there any way you can try to change the DNS on the router to one of the DNS servers I mentioned?

If not, then yes you can try static IP, although please be careful to ensure that no other device is using that IP except for the Nucleus, this can be achieved by setting up a Reserved IP in the router settings.