iPhone and iPad can't discover Roon Nucleus

Roon Core Machine

The Core Machine is a Roon Nucleus.

Networking Gear & Setup Details

I use an Eero router system. The Roon Nucleus is connected by Ethernet to an Eero router.

Connected Audio Devices

Dutch & Dutch 8 active speaker; BluSound PowerNode 2i to Vandersteen passive speaker. Both connected via USB

Number of Tracks in Library

Approximately 125 albums

Description of Issue

My iPhone 10 (iOS 16.2) and iPad Mini (iPad iOS 16.3.1) cannot discover the Roon Core/Nucleus. All I get is screen titled “Choose you Roon Core” and a Roon kinetic icon stating “looking for your Roon Core”. My Windows 10 laptop can discover the Roon Core when set to Fullscreen mode. I’ve tried rebooting the Roon and deleting and then reinstalling the Roon app on my Apple devices to no avail.

I think the first thing to check is that all devices (Nucleus, laptop, iPhone and iPad) are in the same IP subnet. Can you check this?

@Allan_Reiss, in addition to what @Geoff_Coupe requests, can you also confirm that all of your Roon devices are running on the most recent versions of Roon? Roon Remotes may not connect if a Core is running a different version of Roon than the Remotes.

1 Like

Hi Geoff - The Roon Nucleus/Windows 10 laptop appear to have different subnets from the iPhone/iPad. Their IP addresses are below:
Windows 10 Laptop:

The Roon Nucleus is running the current version of the app. I believe that is the case for the iPhone/iPad, as I recently deleted and then reinstalled the Roon app.

Until a few days ago, the iPhone/iPad were communicating properly with the Roon Nucleus.

Thanks for your help,

@Allan_Reiss, it appears your iPhone and iPad are on a separate network from your Nucleus and Windows 10 laptop. The iPhone and iPad are using network addresses 10.0.0.nnn and the Nucleus and W10 laptop are using network addresses 192.168.4.nnn. Do you have another router in your network, possibly from your ISP? If so, can you disable WiFi on it and connect to the WiFi on your eero network?

Hi Robert - I think that’s the issue. I have a Comcast modem/router in addition to the Eero router. The Comcast router is supposed to be disabled, but when Comcast mucks around with the system, I suspect that the Comcast router gets enabled. I’ll get it disabled again.

Thanks for your troubleshooting and help.

1 Like

Hey @Allan_Reiss,

Checking up on this thread, are you still running into issues? Or were you able to get things sorted out?

Thank you @Robert_F and @Geoff_Coupe for the excellent help here! :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.