iPhone/iPad remotes abruptly unable to connect to Core after Roon software update

Roon Core Machine

Windows 11 on Acer computer

Networking Gear & Setup Details

Ethernet connected

Connected Audio Devices

iPad/iPhone as remotes. iFi Zen and Squeezebox Touch for rendering

Number of Tracks in Library

My music library is stored on a Symatec NAS consisting of about 700 cds, <10,000 tracks

Description of Issue

Until the most recent Roon update, the system worked flawlessly. Abruptly after the most recent Roon update loaded, all previously functioning remotes were suddenly no longer able to connect to the core but they continued to recognize the existence of the core and attempt to connect to it. (See attached image)

This abrupt dysfunction happened simultaneously to both iPhone/iPad. The core computer has continued to remain fully functional and continues to access both my NAS stored music files and Tidal streaming.

Hi @Lemuel_Hegwood,

Thank you for getting in touch, and welcome to Community! We’re happy to have you but sorry to see that it was an issue that prompted your first post. We’d be happy to help figure this out!

Please ensure that you’ve installed our latest update, Build 970 on all your devices. It looks like your Core and a few of your remotes are on an older build. After updating restart your Core, Router, and Remotes.

Let us know if this helps. We’ll be watching for your reply and get back to you as soon as we can. Thanks!

Thank you for your response. My core is updated to 970 now and remotes have been updated by downloading a new copy of the app. I don’t see how to ID its iteration number.
In any case, same problem remains. Remotes recognize my core but fail to successfully connect.

Hi @Lemuel_Hegwood,

Thank you for getting back to us to let us know the update didn’t clear things up. From looking at your system diagnostics it looks like your router may have assigned a different IP to your remotes which prevented them from connecting. It looks like it may be resolved for you now.

Can you update us on your current status? It looks like they may be working for you if not.

If you’re still having issues please take a look at this article from our Help Center

Another helpful troubleshooting process is to power down the problematic remotes and hard reboot your Router and Core.

First, turn off your remotes.
Then, power down your router and core
Unplug both,
Wait a few minutes
Plug them back in
Allow the router to fully come online
Power up you Core.
Then power up the remotes

Please let us know if this helps. Thanks!

As you recommended, I did the troubleshooting process by powering down and rebooting sequentially. It worked at first. But shortly after, the problem reoccurred. Please see screen shot from iPad attached. All other systems remain fully functional i.e. wifi connection on the iPad is correct, the core and desktop have fully functional roon.
What can I try now?

Add images

My remotes remain disconnected. I am awaiting a response. I have been unable to connect with remotes for over a month. Terrible service. FYI I have disabled my automatic renewal to Roon.

I received your email a week ago. That very same day I followed your suggested troubleshooting, without any permanent success and I sent a reply which was posted. I have received NO communication since.
I am still without meaningful Roon service. It’s two months since the problem started.

Total frustration would be the best way to describe the purported support Roon provides it subscribers. This experience has made me start searching for other more dependable service providers who will provide timely support when necessary.


Lem Hegwood

Hey @Lemuel_Hegwood,

I’m sorry to hear that you’re still having issues. What you’re seeing is typically an indicator of network problems. How is your Core connected to your network, wired or Wi-Fi?

First, please go to Settings>Setup in Roon and make sure that accept remote connections is still toggled on.

Next uninstall the remote app on the devices that aren’t connecting, restart the device, and reinstall Roon Remote. Please let us know if that helps, thanks!

Add images

Hi Jamie
I followed your procedure and at first the iPad remote connected and was functional.(see image) However, shortly it became dysfunctional as shown in second image. During this entire time, the functionality was normal when accessed from my Windows based computer which houses the core. What next?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.