iPhone remote touch screen sensitivity and choppy scrolling [Investigating]

Hiya,

“The touch sensitivity is quite annoying to be honest. Lots of times a simple scroll or light touch of the screen are registered as a tap and you’re taken inside a release.”

I raised this as feedback for a newer Roon built. Never had any comments from support as to what could be the cause for this behaviour.

I am quite new to Roon so have no idea if this is a new issue or not.

This and the scrolling being quite choppy make me not even want to use the remote on my iPhone. Not a pleasant experience for me at all sadly. Genuinely makes me nauseous.

Remote on MacOS is tip top!

iOS remote and ROCK are both up to date.

Anyone else experiencing this?

try removing the app on the Iph and reinstall.

Done it so many times already. Does not help with the issue and I know I am not the only one :slight_smile:

2 Iph X here and not seeing any issues, also Iph 6s+ and no issues there either

No idea what is wrong. I notice lots of folk on here with the same gear and some are experiencing a particular issue when others don’t. Usually it’s blamed on our network config.

I for one have deleted the app, hard reset the phone and when in use, I made sure there are no other apps running in the background. Tried it connected on wifi to my router and extender - works the same on both.

I just wish it worked as flawlessly as my remote on the Mac.

Hi @RBO, can you share a video of what you’re seeing?

1 Like

Hi @dylan

Here’s the video. You can see it’s not smooth at all. I have zero apps running in the background and took video after I restarted the iPhone.

Gets worse with time, then works, then worse. No idea what to say.

@support It has nothing to do with network gear. It’s just bad optimization of the app, particularly for the newer iPhones. The choppiness during scrolling is horrible on my iPhone 12 pro. Especially when scrolling while my finger remains in contact with the screen. As soon as I lift my finger scrolling is (fairly) smooth.

2 Likes

Hey @RBO,

Thanks for the video :pray:

I’ve tagged @dylan so he can take a closer look when we all return to work on Monday.

Please, stay tuned :nerd_face:

1 Like

Scrolling is still horrible here with high performance iPhone 12 Pro and latest build :frowning:
This should be really easy to fix?

Hey @Markus_Hubner,

Thanks for chiming in and sharing you have a similar experience. We’re very sorry :sweat:

I wish I had the ability to determine whether this is an easy fix. What I can do instead, is take it to our technical and dev team :nerd_face:

If you need further testing, debugging etc. just drop a line here - the vast number of iPhone users affected will help to fix this ASAP as it’s unfortunately really annoying when using Roon as it happens so often.

1 Like

Thanks for the offer, @Markus_Hubner. We’ll keep that in mind :nerd_face:

1 Like

So it’s almost Friday… any response from the team?

Hello @RBO,

We have attempted to reproduce this behavior on an iPhone X with ROCK and we are not seeing similar behavior here.

Can you please confirm, if you try to clear out the image cache on your Roon Settings → Setup → Clear Image Cache, does the behavior improve?

What happens if you try to set the MacOS as the Roon Core, does the same issue occur, or is it only present on the ROCK install? You can temporarily use the Mac as a Core by following these instructions:

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings → General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Thanks!

1 Like

But you do experience the choppy scrolling in playlists etc? This not only happens on iPhone X but also here with iPhone 12 Pro.

Hi Noris,

Thanks for the reply.

Am currently abroad and can’t access Roon. I can however confirm that back when I had the core on my Mac, the scrolling on the iPhone was still problematic.

Will try clearing cache when back home and let you know how it goes.

The remote on my iPad works great by the way.

1 Like

Hello All,

Thanks for the reports, we’ve been able to reproduce similar behavior on some devices and we are looking into this. As per policy, we can’t comment on any timelines here, but thank you all for bringing this to our attention!

3 Likes

Cheers Noris.

Looking forward to your findings.

Cheers @RBO for pointing me here, this is driving me mad.

2 Likes