Issue loading database after upgrade to 1.7

Thanks for the quick reply.
I’ll try and will report back.

1 Like

Hi @noris,

I have reinstalled Roon as mentioned above.
The freshly installed Roon did see my audio device.
Restoring the database from my most recent back-up (still 1.6 don’t know if that matters) did work as well.
Unfortunately after re-launch I get the message “There was an issue loading your database” and we’re back to square one.

  • No audio device
  • Watched folders unresponsive

I will add a couple of screen shots as well.
Hope this helps

Add images

Add images

A post was split to a new topic: Issues after 1.7 update

Hi @Martijn,

Can I please request that you send me a copy of your Roon logs via Dropbox / Google Drive by using these instructions?

Hi @noris

Please find the logs over here:

Hi @Martijn,

Thanks for sending that log file over.

I’m taking a look through it and I’m not noticing any Critical traces contained in it, is this the same log that displayed the “issue loading database” error or have you since re-installed Roon fresh?

I ask because I’m also not noticing that you restored a backup in the logs.

Hi @noris,

My bad, these are the logs from the freshly installed version.

I will restore my most recent back-up once more and will send over the logs from that instead

1 Like

A post was split to a new topic: Error loading database on MacOS

Hi @noris

These should be the right logs:

A post was split to a new topic: Issue Loading Database - Update to 1.7

Hi @Martijn,

Thank you again for your patience while our technical team has been looking into this issue for you.

I spoke with our team today regarding their evaluation of the logs from your install. Sometimes, errors like the one you saw can be spurious, but unfortunately in this case they are seeing signs of low level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced a few reports like this in the past to hard drive integrity issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to install Roon fresh on your Core machine, and roll back to one of your older backups.

If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any older backups, unfortunately you will need to start with a fresh database.

Again, this class of issue is extremely rare for us and you have our apologies for the trouble here.

Hi Norris,

Thanks for getting back.

I don’t understand why everything worked flawless under 1.6 but does not with 1.7.

Seems to me that the issue has something to do with the update and not with my database.

I’ll try an older update and will report back.

1 Like

Hi @noris

I tried a couple of backups, the oldest dating from August, but no luck. Now the restoring stops at around 40%.

Really disappointed with this. Re-editing my db will take a lot of time.

This is the 2nd time I had a “very rare” corrupt database in 2 years. Something that should not happen with paid software like this.

And I really find it strange that my apparently corrupt db worked under 1.6

Hi @Martijn,

Sincere apologies for the frustrations here.

Often times when we have investigated re-occuring corruption, we have found this was due to a faulty piece of hardware - bad RAM, bad sectors on hard drives, Roon being improperly turned off (such as due to power surges), ect.

I can’t say for sure why this occurred on your end twice, but it may be worth performing a disk check or RAM check on your Mac for hard drive issues, I would inquire with Apple on how to do this.

This Roon release had to update every part of your database with the changes we made under-the-hood. It may have been present even in 1.6, but since that area of the database may not have been accessed and now it is, this is likely why you are only now noticing this issue.

A post was split to a new topic: Roon sometimes skips to next song

Thanks @noris for the explanation.
A hardware malfunction sounds plausible.
I was considering to buy a Nuc/Rock as core and so this might be the right time to switch.

One question regarding this: What would you reccomend for RAM in a Nuc8i7?1x 8GB or 2x 4GB?

1 Like

Hi @Martijn,

ROCK is a fantastic solution, I would definitely recommend looking over our ROCK Getting Started guide if you haven’t already, there’s quite a wealth of info there.

I would use two sticks instead of one. This is if one RAM were to fail you could at least have 4GB while replacing the other one. I’ve seen RAM failures to occur from time to time and it’s goof to have a backup in case one goes bad.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.