Issue loading your database - Roon not functioning

I receive the message: “There was an issue loading your database…”

I’ve reviewed other posts with this issue but haven’t been able to determine a solution.

History: My PC was sick - Win 7: Black screen and cursor - nothing more. I had prematurely turned it off and later a virus was discovered. Today the PC is working fine. However, Roon is not functioning.

I uninstalled Roon (but kept settings) and then reinstalled (x64) but that didn’t help.

Not sure on next steps. Appreciate some support.


Hi hsrader,

Do you have a backup of your Roon database, or a recent backup of the whole computer, before the power off/virus issues ?

I DO have a backup. Although there are some variables that might make a difference. I updated from 88 to 94 and then to 64x. I am not sure at which point the back up was made. I am thinking i should reload the build that was running at the time the back up was made. Or maybe it doesn’t make a difference…?

i believe your backup database will still function despite those changes. I’d suggest closing Roon, backing up the current database just in case, and then copying your old backup over the current database, reinstalling Roon and restarting.

That ought to get you back to where your library was with the old backup but you’ll need to recreate playlists, tags and imports after that.

If those things don’t get you on track then we’ll get an investigation started.

I think i followed your directions but no joy.

I have two backups. One from 1/16 (Application, Cache, Database folders) and one from 1/30 (all six folders). I tried with each, but Roon was not happy. It might be a sequence thing. I did reinstall fully and that worked but with out recognizing any prior personalization.

I would like to keep working on this to see how i can bring back my settings from 1/16, at least. Maybe i need to load build 88 rather than 94 and then update to 94…?

A few minutes later… I ran .exe from Dec 13th. Roon starts up, but is a fresh start – it is asking for log in and what databases to copy. It looks like it is no different from starting with the latest software - in each case my personalization is not recognized.

I need to step away to clear my head on this… not sure what to do next in order to reintroduce my 1/16 settings…

I think we need some people with jellyfish next to their names to assist. I’ll drop some flags for @mike and @vova to look in here. You’ve done the right thing by taking a backup and I really hope they can get it working for you.

Hey @hshrader – sorry for the trouble here. I’m going to PM you and we’ll have a look at the logs so we can figure out the best way forward here.

Stand by!

Mike - thanks for the shout. The issue is resolved now.

1 Like

@hshrader how did you resolve this? I’m getting the same message.


Hi Adam,

I wish I could be specific. I seem to have loaded the right version of Roon that corresponded with the right backup files. I don’t recall the sequence and Roon leadership didn’t end up providing support.

I think the trick was opening Roon with the back up files in the right place rather than putting them in place after Roon is installed and on.

I know the frustration—I hope you resolve quickly!