Issue recognizing two Dietpi Allo GUI Roon Bridges [image issue - fix coming]

(Reposted from Audio Products forum, no response there)

I have two RPi Allo DigiOne devices configured as Roon Bridges. They are running the new Dietpi Allo GUI. The Roon server is build 269 on Windows 10.

Roon server recognizes both of my DigiOne Dietpi Allo GUI Bridges, but only one at
a time. If either Bridge is on the network, Roon Server sees it and plays music through it. But if both Bridges are on the network at the same time, Roon Server sees at most one Bridge. Never both at once. I’ve tried “add network device” and this only offers HQPlayer as an option. “Scan for devices” doesn’t detect the other device either.

Each Bridge is a fresh install of Dietpi Allo GUI. Nothing was “cloned”. The devices
have different IP addresses.

Previously I had one of the DigiOne devices configured under Moode OS as a squeezebox, and Roon could register with it and with the other device (configured under Dietpi Allo GUI Roon Bridge) simultaneously. Everything worked fine. I could go back to that, but I’d rather have both devices configured with Dietpi Allo GUI.

Any help appreciated.

Addendum: I just switched one of the Rpi’s to be a Squeezebox under the Allo Dietpi GUI OS.The other Rpi is still configured as a Roon Bridge under Allo Dietpi GUI. In this scenario Roon Core sees both devices properly, and can play through either or both.

It seems to me that Core can’t distinguish between the two Rpi’s when they are configured as Bridges under Allo Dietpi GUI.

I have 5 RPi/DietPi endpoints with no problems, however I don’t use Allo GUI.

I use 4 RPi/DietPi endpoints, all with Allo GUI, without problems. Perhaps you should give them unique network names (instead of the default “DietPi”), which is easy to do in System Settings. Don’t forget to Save Changes and Reboot.

Did you clone the DietPi microSD card ? It’s necessary to set up DietPi separately on each device.

Nothing cloned. Each device was a fresh install of Dietpi Allo GUI.

1 Like

Thanks Brad. I did assign unique hostnames during the initial configuration, so that is not the issue here.

I have the same issue, Two RPI Roon Bridge Allo GUI of DietPi, both boxes Digione. @Dan_Knight is aware now for 6 days but has not yet reverted.
Changing hostnames does not resolve, I’ve changed one box to Ropieee image and all is well.

Everything you’re describing sounds like these devices aren’t getting unique IDs. Can you walk us through the exact steps you’re following to flash the two units?

these devices get a dietpi web gui image specifically prepared for Allo hats. Its a complete image with Roon Bridge already installed. uninstalling Roon Bridge and reinstalling it does not remedy the situation, changing the hostnames of the devices to unique names, does not remedy

As requested, here was my exact process in bringing up the two RPi’s on my system:

1-Downloaded the file from: and unzipped file.

2-Used Etcher to burn the unzipped file to a micro sd card, installed card in RPi #1 and powered up.

3-RPi #1 was assigned an IP address by router based on previous reservation by MAC ID, in this case x.x.x.50.

4-Logged into GUI at reserved IP address. Configured for DigiOne HAT. Configured a hostname of LoungeHP. Enabled Roon Bridge and disabled all other services. Saved and rebooted multiple times as appropriate.

Roon Settings then showed RPi #1 present and ready to enable. Enabled. Played music. Was happy!

Repeated 1-4 for RPi #2, which had a router-reserved IP address of x.x.x.80. In Allo GUI, configured hostname of LRMAIN.

After bringing up RPi #2, Roon Settings did not show RPi #2 at all. “Scan for devices” did not detect anything, nor did “Add Network Device”

Rebooted everything including router and server and both RPi’s multiple times, still only RPi #1 showing up in Roon Settings. Only way to make RPi #2 show up was to power down RPi #1. Was not happy!

As a work around, I reconfigured RPi #2 under Dietpi Allo GUI, disabling Roon Bridge and enabling Squeezelite. That works, and the snip below shows the result.


Thanks for all assistance.

1 Like

I’m not having the same issue. But for my setup I installed dietpi (without Allo) and then did an update and upgrade. Then ran install 159. Wonder if it is something baked into the initial image.

In my case I didn’t install Roon before 159 but that could be another option. Install it, get Roon seeing it. Then install the rest.

@p-cubed -

I know you are tired of hearing this and I don’t blame you, but it still sounds like a collision of IDs. I found this solution to a similar problem in another thread. If you want to try it, you’ll probably have to change some directory names, etc. I know very little about linux, afraid I can’t help with that. Probably should run on both endpoints.

1 Like

Hey @p-cubed – I’m checking with Allo to see what happened here.

In the meantime, I suspect that @xxx’s workaround will resolve this, but let us know if that’s not the case.

Thanks for the report!

Is it an issue with Allo or the DietPi image? I could recreate it using the prebuilt image, but not with installing manually.

Thanks Slim! and thanks mike! .

I was able to remove the ID’s using the instructions in: Can only see one USBridge at a time [Solved, cloned DietPi] . After rebooting everything, I have Roon Bridges running on both RPi’s and registering properly with the Core. Nice!

This seems to verify that the Dietpi Allo GUI image installs with non-unique ID’s and is likely to create problems in systems where it is installed on more than one device. I’m not sure who needs to be informed of this, as I’m not sure who maintains this. Please pass this on to the appropriate person.

Thanks everyone. Enjoying the music!


I think that would be @Dan_Knight.

Hi All,

Apologies for the delay, family emergency.

Many thanks for letting us know of this issue, and the solution!

We’ll get this fixed in our next Allo GUI images (v3), and also patch for DietPi v158 update.
In the mean time, please see the following solution for a resolution: