Issue: Roon detects only 2 out of 3 SOtM sMS-200 Neo Endpoints

It seems you might have the priority backward. Roon Ready is ‘better’ than Roon Tested.

Roon Ready means the device can be used as a networked Roon endpoint.

Roon Tested just means that the device will work wirth Roon, it isn’ t about endpoints.

Have you tried turning off all SOtM devices but one and then trying to connect? Perhaps once a device is connected to by Roon it becomes easier to discover later. ( I don’t believe in the Tooth Fairy. It just sounds like it.)

Hi Slim_Fishuttz,
Thanks for asking.
She responded almost one month ago and has a link to this issue. I resent today, because all I’ve heard were crickets. thx g

Sun 15/11/2020 18:14
Thanks for the prompt feedback and the information, I would ask some help from our engineers as well.

I will get back to you the soonest.

Best regards, May"

Thx for the explanation of ready and tested. Unfortunately, the ready are not working, but the tested devices are. :frowning:

“Have you tried turning off all SOtM devices but one and then trying to connect?”
Thanks for that. One month ago, when all 3 SOtM devices would not connect, I tried sequentially without success. So, I left everything powered up and without any changes by me in slightly more than 2 weeks later the second SOtM device showed up in roon Settings/Audio. The tooth fairy does exist.

Unfortunately, one month later it changed configuration (without input from by me) and is unreachable. The tooth fairy left town. :slight_smile: That type of results makes the SOtM software suspect to me. I always ask, “What has changed?” Nothing on my LAN.

Despite being only tested, I find it amazing that the old Sonos Connects work vs. not working. I just wish that they were better than 16 bit, but that’s irrelevant to the SOtM issues.

1 Like

I suppose you’ve re-flashed the OS cards?

I flashed the device (latest IP that does not show in the roon app, and nothing changed. It is pingable in less than one millisecond and visible in the Eunhasu browser application, but not roon Settings/Audio visible.

I even tried DHCP reservation and then disabled. I reset the device by allowing it to remaining powered up and disconnected from the LAN. New IP, reachable by ping and browser, but it is invisible to roon in Settings/Audio.

I’ ve had an SMS-200. The OS card can get burned, in subtle ways. Some of your problems sound like a bad card.

I would, as a test, take the card that’s in the device that Roon can find and swap it into a device that Roon can’t find, and vice versa. Easy and can’t hurt.

If the discoverability of the two devices also swaps, then the card was the problem.

Hi Slim_Fishguttz & ronfint

Thanks for all the great suggestions. A couple of weeks ago, I swapped the card without resolution.

I kept track of all the time that I wasted on the issue . . . 67 hours. I resolved the issue and at the same time completed the RCA (root cause analysis). The root cause was not my equipment or LAN.

The issue is the SOtM code. The hint of the resolution is in name of one my DACs (ronfint was on the right track). They should not take the name seriously and not write code like that. SOtM needs to write better code. Fortunately, I have 4 DACs for 3 systems and that helped with resolution.

May Park of SOtM can contact me at my personal email. I am an IT management consultant and SOtM can working something out with me for the answer and the 67 hours of my time. I am holding SOtM ransom.

Unfortunately, the issue might recur for users using multiple endpoints and specific DAC OEMs.

Feedback for roon devs
Development needs better hooks in the code that throw more verbose events in the logs. For example, if an endpoint is reachable through ICMP and the roon service cannot remote call/detect it and load the endpoint and DAC in device setup, then the application should throw event failure errors in the logs. Also if there is a universal DAC device driver (stub code) in the SDK, then great. If not, then maybe it should have one?

roon you can close this issue. RCA is SOtM code.

thx everyone.

1 Like

Wow, that’s too bad! I wish you were able to find a solution instead of just a cause. Hopefully you can get your money back for those! Please don’t throw any of them away out of frustration! I am interested in what Roon and SoTM will come up with to fix all this too

SOtM makes very good hardware, but the code and support needs improvement. They responded to me recently, but not too different from the earlier response one month ago.

" 박정은
Sun 13/12/2020 17:23
To: * You;

  • sotm
  • 이일원

I’m sorry that it is still not working properly, this issue has been escalated and our engineer will get back to you soon with some request.

Thank you.

Best regards, May"

I hope “our engineer” is a usage mistake and not that they only have one engineer!

Yeah. That’s funny. It looks like a cut/paste response unfortunately.


1 Like

I can’t comment on their code since I know nothing about all that, but hopefully the “engineer” won’t be too busy and will get back to you soon :laughing:

I have two end points so far but only one is an SMS-200ultra neo. I was about to try and get a second one, but the upgraded Crux Audio Special Edition and with the master clock input (just to try and see if a external master clock makes any difference) but I have now been re-considering. I wonder if it is the overall number of endpoints that is causing the issue or is it the number of SMS-200ultra endpoints that is causing the issue.

I hope their engineer got back to you and you figured it all outout! If you haven’t though and are thinking about throwing them away, please let me know first as I definitely want those upgraded versions and we could work out a deal . Just wanted to throw that out there as an option fo you if need it . Best of luck and Happy Holidays!

Actually, it is the SOtM software that is root cause. I did a workaround.

I would prefer that SOtM provides a solution and support, rather than me offering up temp fixes to the community that might not work well in all scenarios. SOtM has not responded beyond their perfunctory our engineer will take a look at it.

You might not have an issue, but then . . . .

1 Like

Serial Number MP02739 stopped working without any changes by me. It is unreachable on my LAN, not listed in roon audio devices, fails ping, or access through the Eunhasu web browser configuration application. Flashing the SD did not help. The second green LED (right) on the front panel does not illuminate.

Requesting an RMA from SOtM, because the endpoint is dead and will not power up.

Fortunately, I have two other SOtM endpoints that are still working. I imagine that 2 of out 3 endpoints working is good? Maybe not.

33.33% failure rate

15Feb21 Update
The other two SMS Neo endpoints are still working.
The OEM SOtM will replace a broken PCB board under warranty. Thank you SOtM.
Will update status after receiving the repaired endpoint

1 Like

6Mar21 Update
No status from SOtM on Serial Number MP02739, and only crickets heard.
The other two SMS Neo endpoints are still working.

Let’s wait and see how long SOtM product support takes . . . . :slight_smile:

The repaired defective SMS-200 arrived without any correspondence and appears to work for now. Two months.

You can arrive at your own conclusions. I intend remaining agnostic.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.