Issue: Roon detects only 2 out of 3 SOtM sMS-200 Neo Endpoints

Core Machine (Operating system/System info/Roon build number)

  • NUC7i7BNH server-Crucial SSD 1TB with library (7584 tracks), WD My Cloud Pro PR2100 10TB (backups only) RAID1, 20TB raw
  • OS Version 1.0 (build 227) stable
  • dB: 98% of 114 GB available.
  • Server: Version 1.7 (build 667) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  • Network: DHCP using reservations for ROCK and all SOtM sMS-200 neo endpoints.
  • All three sMS-200 endpoints are browser accessible and configurable from anywhere on my LAN. So, network Ethernet access of the sMS-200 Neo endpoints from anywhere on the LAN is not an issue. Is this a multicast issue?
  • There are no FWs.
  • Remotes: 2 PCs, Android tablet, Android mobile device
  • TPLink TL-R600VPN Router, TPLink TC-7610 DOCSIS3.0, Netgear GS108, 3 Sonos Connects in the process of replacing with 3 sMS-200 Neo endpoints, TPLink TL-SG1008D1
  • APs: TPLink AP500, TL-WA801ND.
  • The TPLink TL-R600VPN router blocks UDP multicast broadcast traffic by default and is unconfigurable, but that was not an issue for the Sonos Connect endpoints working for years without issue. SonosNet uses STP, and I do not know if roon plugs into that bypassing a lot of the UDP issues. A meshed topology is definitely the best way to go.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  • qobuz subscription
  • 3 DACs all USB connected: Musical Fidelity xDAC V8, Topping E30, Schiit Modi Uber

Description Of Issue
Roon detects only 1 out of 3 SOtM sMS-200 Neo Endpoints
The upgrade swaps of my endpoints are stalled.

Please help/direct me. It must be something really simple.

My roon labs network had three (3) zones with Sonos Connect Ethernet connected endpoints that worked well for years without issues.

All three endpoints were connected to external DACs. Control is through PCs, Androids, etc.

What changed?
The only cnange was removing and replacing sequentially all three Sonos Connect endpoints with SOtM sMS-200 neo endpoints.

The first zone sMS-200/Sonos endpoint swap worked and still works well without issues.

The second and third zones sMS-200/Sonos endpoints swaps are undetectable by roon.

Remediation tried?

  • Cold booted all LAN devices, roon core server, and all endpoints.
  • Interestingly, the first sMS-200 endpoint was the farthest from the ROCK server. I suspected that the most remote zone would prove problematic but I was wrong. It works well. The closest two zones are the issue–undetected in the Settings/Audio menu.

Thanks, g :slight_smile:


This text will be hidden

I’m not familiar with SOtM devices, but intuition tells me you have to give them distinct names. This is what I found in the user manual (

“Host name: A name of sMS-200 appearing on the network. If you use multiple sMS-200s on the network, you will need to use different host name for each sMS-200.”

Did you already do that?

“. . . you have to give them distinct names”
Did that already. Thanks much.

roon has always had issues with discovery, because like many streaming services (except NetFlix) roon uses multicast. Multicast is a good protocol for streaming, but it can saturate a LAN and is blocked by most home routers. If that is the issue, then I would need to replace with a Cisco or equivalent that allows a multicast config.

Note: this should have been a doddle, i.e. a simple PlugNPlay, where I swap out 3 Sonos endpoints for 3 SOtM endpoints. It isn’t. :slight_smile: We should note that the Sonos endpoints did not have any issues at all . . . for ages.

Tagging @support

Hi @racingdriver,

Managed switches and non-functioning multicast networking gear can cause issues with device discovery as mentioned in our Networking Best Practices Guide.

If you try to connect your Core + Endpoints to an un-managed switch instead, does that help with the issue?

Hi Noris,
Thanks for the response.

  • All my switches are unmanaged. The Endpoints (3) and Core connect to them.

I am simply swapping/replacing all three of my Sonos Connect endpoints for SOtM sMS-200 Neo endpoints. The Sonos endpoints worked for years and were discoverable by roon.

Only one (1 of 3) of the SOtM endpoints was discoverable by roon, and it was the farthest away on the network from the Core. I moved and connected the Core to the same switch that one of the undiscovered SOtM endpoints used.

Now, none of the SOtM endpoints are visible in the roon application under Settings–>Audio. I restarted all devices including the Core without any change.

In fact, I am moving and connecting the Core to different points on the network trying for different results. That did not help one iota. In fact, now no SOtM endpoints are visible at all.

My Test: Without any changes to my existing network, I plugged in a Sonos Connect (AC power and RJ45). The Sonos Connect appeared immediately in the roon application on the Settings/Audio devices page and was accessible.

If the Sonos endpoints work instantly and the SOtM endpoints do not, can we conclude that ostensibly my current network configuration is probably not the issue? Or not?

When swapped in the same network, why do the Sonos roon tested endpoints work and the SOtM roon ready endpoints do not?

Next steps?

thx again,

On the Settings/Audio page only 1 of the 3 sMS-200 endpoints, but the 3 Sonos endpoints in the same physical network connection locations show. Is that the difference between roon ready and roon tested?

Hi @racingdriver,

Thanks for those additional details. Are you able to access the Eunhasu Webpage fro all your SOtM Endpoints? Do you have a DAC connected to it? I believe you need to have a DAC connected to the SOtM for it to show up in Roon. This thread may also help:

Hi noris,
“Are you able to access the Eunhasu Webpage fro all your SOtM Endpoints?”
Yes. As stated in my first post, I can access all three SOtM endpoints using a browser

  • –> "All three sMS-200 endpoints are browser accessible and configurable from anywhere on my LAN. So, network Ethernet access of the sMS-200 Neo endpoints from anywhere on the LAN "

“Do you have a DAC connected to it?”
Yes. I have 3 DACs connected to all 3 SOtM endpoints.


Sorry, the additional thread information provided did not help. There are no firewall issues, etc. Please remain cognizant that roon does not have any issues immediately connecting to all 3 Sonos endpoints at the same network locations.

Restating the issue:

  • All three SOtM sMS-200 Neo endpoints have DACs and are connected to the network and accessible by name or private IP address in a browser
  • Only two of the three SOtMs are detected in the roon application.
  • All three SOtM endpoints are connected to the network at the same location as the Sonos endpoints. All three Sonos endpoints are detected immediately by roon, but only 2 of the 3 SOtM endpoints are detected. Unplugging any or all endpoints of either OEM makes no difference.
  • Bottom-line: roon detects only 2 of 3 SOtM endpoints

If roon detects three Sonos endpoints immediately without issues, then it should detect all three (instead of 2 out of 3) of the SOtM endpoints also . . . but, it does not. Screenshot follows:

One could conclude that the protocols in use by Sonos differ from SOtM. Sonos uses STP. Does roon leverage STP for Sonos and not for SOtM or neither?


1 Like

Hello @racingdriver,

Thank you for providing those additional details, it is appreciated!

For next steps, I would like to take a look at your Roon logs to see if there are any errors or if the other SMS show up at all when Roon tries to detect devices.

Can I please ask that you use these instructions to send me a set of your ROCK logs via private message (click my name -> message)?

Hi noris,
I sent you a DM with the archived log files.

Hi @racingdriver,

Thank you again for providing the Roon logs!

There are no traces of the third SMS-200 endpoint, with the IP of anywhere in the logs unfortunately, but I do have some follow-up suggestions:

Can I ask, have you by any chance tried to factory reset this SMS endpoint yet? If not, this would be my next suggestion since the other two are showing up as expected.

Where are the other two SMS endpoints plugged in compared to the third one? I know you mentioned you tried swapping some of the cables around, but this was before the 2nd one showed up (please do correct me if I’m wrong though).

How did you get the 2nd SOtM zone discovered? Can you repeat the same procedure for the 3rd SMS zone?

Hi Noris,

Thanks for the response. Yes, I scanned the logs, found 2 of the SMS devices, but did not find any entries for the 3rd SMS device ( Yet, I did find the Sonos Connect devices–all three immediately and grouped together. So, there is not an apparent problem in my LAN.

The Sonos Connect ( is connected on an RJ45 port next to the SMS device ( on the same switch. I swapped the switch ports between the SMS device and the Sonos Connect. No change in outcome with the SMS device remaining undetected by roon and the Sonos Connect does not skip a beat continuing to work.

Per SOtM instructions, I reset the SMS endpoint to no avail or change in outcome. Please remain cognizant that the Sonos and SMS devices are listed in my router. The SMS endpoint is still pingable (average of less than 1 millisecond) and reachable by Chrome web browser. Here are screenshots:


The issue remains, i.e. SOtM SMS endpoint is undetectable by roon, but definitively on the LAN, pingable, and reachable by Chrome web browser.

“Where are the other two SMS endpoints plugged in compared to the third one?”
Both the other two SMS endpoints are in adjacent rooms sharing switches with two Sonos endpoints on adjacent RJ45 ports. SMS endpoint is in a third room next to my router and on the same switch with the 3rd Sonos device (

“. . . tried swapping some of the cables around, but this was before the 2nd one showed up . . . .”
I tried swapping cables, endpoints, rebooting all switches and routers, before and after the 2nd SMS endpoint was detected by roon.

“How did you get the 2nd SOtM zone discovered? Can you repeat the same procedure for the 3rd SMS zone?”
I got the 2rd SOtM zone discovered by waiting for one week. Weeks later, the 3rd endpoint ( is undetected by roon, but detected by ping and in a web browser. Unfortunately, or maybe fortunately the Sonos devices show up. I even tried removing the Sonos devices (I don’t believe that would have any impact). No impact to the SMS endpoint issue. Screenshot:

The Sonos devices still show up in milliseconds, despite my efforts to change their connectivity status. The SMS endpoints on the other hand limit themselves to two devices, even though all 3 devices are reachable by ICMP and by web browser.

  • Does roon leverage Sonos STP?
  • What protocols are in use for roon “ready” SOtM endpoints? And are they the same as Sonos?
  • Has roon contacted SOtM? I shared the link to this issue with SOtM, they mentioned that they would have their engineer look into it. All I’ve heard is crickets.
  • At $2100 for three SOtM endpoints only it is possible that there are not many roon subscribers with 3 or more SOtM endpoints. Maybe multiple endpoints to SOtM means 2 endpoints only and not more than 2 with a limit of two?
  • Has roon tested multiple SOtM endpoints yet, i.e. more than 3 or 4 or 5 on a LAN?
  • Since Sonos devices are tested and SOtM are only ready, what does roon ready vs. tested mean please?

Since the 3rd SMS device is reachable by ping and browser on my LAN, it is possible that the root cause of the issue is connectivity between the roon application and the SOtM endpoint.

Next steps?


Hi noris
New information
The second SOtM autonomously reconfigured the volume control from roon variable to fixed. What changed in my LAN and environment? Nothing

All attempts to reconfigure failed. I pulled the power and dropped it from the network and roon devices. :frowning: So now we return to only 1 out of 3 SOtM SMS-neo endpoints working.

It should not be this difficult. The inferior 10 year old Sonos Connect endpoints work and are a doddle. Dead easy, simple.

Sonos? They keep working, but unfortunately are 16bit. So, no joy.

Although I spent $2100, I am ready to chuck all 3 endpoints in the dustin bin and simply take the loss. If all 3 of the SOtM endpoints do not work with roon, there is no point in adding frustration to my life. I have bigger fish to fry. I can return to searching for roon endpoints that work well in multiple locations–we call it scaling out horizontally.

Since SOtM is a roon ready endpoint, what are the recommendations from roon and SOtM?

I apologize if this has been done and is obvious, but are your dacs all turned on? Roon won’t see an sms 200 unless the dac connected to it is on.

Hi ronfint

No apologies necessary. :slight_smile: Thanks very much for the helpful information. Good to know.

All three DACs and SMS endpoints (I secretly hope that the SOtMs just die, self-destruct, commit suicide) are powered up 24x7 and connected.

The second SMS neo automagically reverted configuration to a fixed volume and will not allow roon variable control. Gave up and powered it down, dropping it from the network. I decided to power it on again, and let it percolate.

I suspect that scaling out horizontally (to many zones) is not a feature that most endpoint OEMs functionally and stress test thoroughly.

My objective was to upgrade/replace the 16 bit Sonos Connect endpoints removing them as bottlenecks and improving throughput. One month later with a lot of swapping out, rebooting, reverting, configuring, and moving around . . . without success.

I am almost ready to pay someone to remove the SOtM SMS-neo limited editions from my life, if they can come up with a same level of quality endpoints that can scale out in zones reliably, as well as the old long-in-the-tooth Sonos Connect endpoints.

Thanks again,

I’m not sure what the problem could be. I have had an sms 200 ultra for many years and don’t ever recall having this problem. If you can see all your sms 200s in eunhasu, then the problem may be the usb connections to the dacs. Perhaps rebooting both sms and dac in one of the two orders will lead to the dac seeing the sms 200.

In fact, I just realized that there is an easy way to check whether your dac sees its sms 200. In eunhasu click the gear symbol over “Roon Ready”. Then you can check if your dac appears in “Audio device config”.


One (1) out of the three (3) sms 200 neo limited editions works well. It’s the other two that are problematic.

All 3 devices are visible in a browser together with their respective DACs (screenshots earlier in the post and I will do it again in this post) and pingable in milliseconds or less. One out of three works, the second occasionally without changes by me, and the third is roon application brain dead–invisible in Settings/Audio.

I’ve swapped DACs, etc. Yes, I agree too that the DACs could be suspect. So, I swapped them among locations. No change. Here are shots from the SOtM Eunhasu pages:

The office SMS (undetected by roon)

The occasionally available SMS (second Topping E30)

The always available SMS

The SOtM or roon applications are suspect at this point, because at lower levels of the OSI (ICMP ping) the devices are visible from anywhere on the network. Plus, all 3 devices are visible in a browser.

It is important to note that the Sonos Connects work instantly in the same network location and on the same ports with the same DACs swapped.

“I have had an sms 200 ultra for many years . . . .”
How many SMS 200 ultras are you running please–two or three or more?

thx g

Sorry — one. I’m beginning to understand that you suspect that having more than one is the problem. I apologize, I have no experience with that.

Ah. No problem and thanks, Ron. That helps a lot because we’ve done everything from a single device perspective. There no issues with one, but greater than one SOtM device and the software either roon or SOtM has issues.

I suspect the Korean OEM software issues before I would roon. Why? Sonos Connect endpoints are detected immediately in less than milliseconds. The Sonos devices show up in the roon logs also.

No one has given me an answer on the technical differences between roon ready and roon tested.

Sonos is tested, but SOtM is only ready. I would state that SOtM is not ready for more than a single standalone device.

noris & roon tier 3
Can you please weigh in?
Should I just chuck all three SOtM “silver” limited editions in the bin or send them back to the OEM, and restart my search for 3 endpoints that can scale like Sonos?

I know that I’ve spent 10 times as much time during the last month than the $2100 spent on the SMS devices. Time is money. What do you recommend for endpoints that have proven scalability like Sonos, but with performance numbers like the SOtM SMS neos?


When you asked her, what did May Park say about having multiple SOtM devices in a Roon system?