Issue with connecting and assigning Roon Core

Core Machine (Operating system/System info/Roon build number)
Windows 10/ Intel NUC i5 10th Generation Mini PC Kit with HyperX DDR4 SO-DIMM 4GB RAM with 2 Hard Drive (SSD WD Green 120 GB M.2 2280 for Roon Software, SATA WD Green SSD 250 GB for Music Storage). Video of hardware:

I have 1 Asus Desktop and 1 Acer Laptop with no issue to be assigned as Core Machine, however when trying to assign the new device (spec above), it says that I have 0 device left to assign and I am unable to proceed. Please not I am trying to switch, not add additional core. I only have 1 license and thus need to switch from either my Asus Desktop or my Acer Laptop to my new Mini PC NUC.

The video of the problem is posted on Youtube link here:


You are only allowed one core to be active per license. How many licenses do you have?

Hi @Peera_Hutasuwan,

As @Rugby mentioned, you are only allowed on active Roon Core at a time per license.
If you wish to use the other PCs running Roon as remotes/clients, you can certainly do so, although keep in mind that the Core needs to be powered on and accessible via the network to use the Roon remotes. See Running Roon as a Remote Guide for instructions on how to set the PCs up as remotes with the Core.

Yes I understand. I only have 1 license and I only want to switch core from either my desktop or laptop. I was however, unable to do so as it always asked me if I am online or not. It appears that Roon only recognize my desktop or laptop to be able to be used as the core and not my Intel NUC Mini PC.

This is what it looked like when unauthorizing my desktop ASUS.

This is what it looked like when trying to authorize my NUC Mini PC.

It keeps asking me if I am online or not and when I clicked Retry, it just keeps refreshing and nothing happens. When I tried to click Unauthorize on the ASUS, it also keeps refreshing. And the weird thing is that I have already Unauthorized the ASUS desktop from that ASUS desktop directly, why is it still listed here as Authorized?

Detailed video can be seen here:

Sounds like the mini pc isn’t seeing the roon servers, hence the are you pine message.
Are any of your cores up and working?

Yes I was able to assign my Asus Desktop as core or my Acer Laptop as Core. Just not this Mini PC. But nevermind I used an older Mini PC and it works now… I dont know what happened with this new Mini PC even though the spec is better. So consider this insolved but closed then.

1 Like

Hi @Peera_Hutasuwan,

Thanks for the additional information here! Since just the Mini PC was affected, I would check for any firewalls which may have been interacting with Roon if you ever wish to take another look at having the Core on that machine. In any case, glad to hear you sorted the issue out with the Asus Desktop/Laptop combo!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.