Issue with iPhone working as a Remote with Surface Pro as the Core

Core Machine (Operating system/System info/Roon build number)

TEXT GOES HERE Surface Pro (5th Generation) Model 1796 i5 running Window 10 Pro Processor Intel ® Core ™ i5-7300U CPU @ 2.60GHz 2.71 GHz
System Type 64 bit operating system, x64-based processor

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Cox High Speed Internet - Fastest Cable service available in my area
Modem / Router is a Panoramic X-Finity
eero mesh / network extender incorporated into the system
Regularly Test Speed of Network - 140 Mbps Download / 30 Mbps Upload / 16 ms - average speed test results


Lumin D2 is the endpoint - connect to the internet via a ethernet cable hooked up to a eero pod extender
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Connected via RCA cables from the Lumin D2 to a Primaluna Evo 400 Integrated Amplifier

Description Of Issue

Roon works if i use my Surface as the Core and remote. I have tried to use my iPhone per the recomended set up, downloaded the App, initially worked for a very short duration of time, every since I get an error message:
Windows 10/::ffff:, version 1.7 (build 610 stable continues to try and connect, says connecting with a yellow colored circle and then gives me a connection failed message and then it cycles through trying to connect. I read a thread that refrenced trying the 32 bit version of Roon on the Surface due to an issue with the 64 bit version interacting with the Surface, didn’t fix the issue. The screen on my surface will also periodically become unreadable, green, red, varoius colors block out the righting on the screen inside the Roon App. Once I click out of the Roon app screen is fine, normal.

Have you configured the eero to run in bridge mode?

1 Like

Hello @Matthew_Miller, wklie has the right idea here. Please let us know!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.