Issue with Logitech G935 headset

@support Were these problems resolved in the end? I have what it seems like the same problem as @Gary_Cardinale. I’m using a Logitech G935 USB headset on a laptop, which also happens to have Realtek HD audio as a default system speaker output.

  1. When using the Realtek Audio (via WASAPI) music plays fine through the laptops speakers.
  2. When enabling the Logitech G935 in Roon (via WASAPI) al played songs are skipped, no sound.
  3. When playing music via i.e. the Qobuz app (via G935 WASAPI) everything plays fine. Al other apps/windows sounds also work fine.

See below some screenshots of my roon audio setup and G935 settings (default). Last screenshot is from the Qobuz app.


Hi @willemzout,

It looks like you have exclusive mode enabled in Roon while the other screenshots shows non-exclusive mode. Can you try to use the Exclusive Mode driver in the Qobuz app and see if that has the same issue or try disabling Exclusive Mode in Roon?

Also, you should be aware that Realtek drivers have caused issues with Roon, including symptoms of audio devices failing to appear. If you are not actively using the Realtek driver with their software, I would try using the Generic driver for laptop instead of the Realtek-specific one.

@noris thank you for the suggestions! Unfortunately they don’t solve my problem. I tried the following, to no avail:

  1. Installed the Generic Windows drivers.
  2. Disabled exclusive mode in Roon for the G935.
  3. Disabled Realtek device in device manager altogether.
  4. Disabled Nvidia HDMI audio devices (see screen)
  5. What I noticed is that in de sound config for the G935 it’s known as a 7.1 speaker setup (see screen), as it being a gaming headset. Tried al sorts of surround options in Roon (7.1/5.1/2.0, both multichannel mixing options).

So no luck so far.

Hi @willemzout,

Thank you for performing those tests. I have been discussing your case with our hardware team and the next step for us here would be to look at logs. Can I please ask that you:

  1. Load the Roon defaults for the Logitech zone (under Device Setup -> Load defaults)
  2. Try to start playback to the gaming headset
  3. Note the exact local time + date + track you tried to play that failed
  4. Let me know this info here

Once I have the timestamp + track into, I can enable diagnostics mode and that automatically uploads a set of logs to our servers. Thanks!

Hi @noris, I’m on a holiday for 3 weeks from today. When I’m back I’ll carry on with your suggestions. Thank you again.

1 Like

No worries @willemzout, let us know the results when you return. Safe travels!

Hi @noris, it took me a while to get back to you, but here we go. I followed your instructions and the problem still exists.

At 9:50am local time I played the song:

It skips the song and all upcoming songs as well. Hopefully you can follow up with this information.

1 Like

Hi @willemzout,

Thanks for the timestamp! You experienced this issue when the DAC was connected to the Windows PC, correct?

Can I please ask that you open up a Windows Explorer window (the one you use to navigate to C: / D: drive) and type in %localappdata% in the header.

Then, you will see a few Roon-related folders there, please access Roon/Logs and RAATServer/Logs and send me the files located in those folders.

These instructions provide more information, but the difference here is that I would like RAATServer logs as well, thanks!

Hi @noris,

The DAC is indeed connected to my laptop. At least, I guess it’s a DAC as well; for sure it is a transmitter specifically for the wireless connection to the G935 headset. It’s a dongle the size of a USB stick.

Just to be specfic, I use my laptop as a Roon client only. The server is another PC. However, I do have the log-files you ask for on my laptop. I’ll send those to you.

Hi @willemzout,

Do you have the driver installed for the dongle? Are you able to connect the headphones via 3.5mm jack and they work as expected?

How exactly did you perform this test? I would try to set Roon to output 7.1 in Device Setup and also ensure that you have “Send Stereo content as 7.1” checked.

Hi @noris

Solved, the combination of output 7.1 in Device Setup and also ensure that you have “Send Stereo content as 7.1” did the trick.

Btw, a connection via 3.5mm jack also works fine, as it bypasses the driver and uses default system output in Roon.

Thank you for the support!

1 Like

Hi @willemzout,

Thanks for letting me know the 7.1 suggestion worked out nicely for you, hope you have a pleasant listening experience and if you run into any other issues with Roon, please just let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.