ISSUE WITH NEW 1.8 UPDATE || Roon Playback stops when any other Windows 10 sound (System, Discord, WhatsApp, or other app, video, etc) occurs

Core Machine (Operating system/System info/Roon build number)

Unraid - Docker container

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluetooth Wireless headset

Description Of Issue

My Roon client is installed on my desktop computer which I work on. My Roon Core is installed on my UnRaid server in the other room. Previously this was working fine. When I installed Roon 1.8 - this issue arouse

Hello all,

This only started after this most recent Roon 1.8 update. Basically the issue is:

Whenever my computer has any other sound occur, the playback on my Roon player stops (mutes), the system sound plays, then the Roon playback continues. Its quite annoying. Let me give you some examples:

I am listening to a song, then on my Windows 10 desktop computer, I receive an:

  • WhatsApp notification of a new message
  • Discord notification of new message
  • I open VLC media player and play a video clip
  • etc - any other sound which occurs on my Windows 10 computer whatsover.

So it goes like this:

  1. Music is playing
  2. Music pauses
  3. System sound (for example - one of the ones I described above plays and beeps)
  4. Music unpauses
  5. Playback continues

Its quite annoying. This never used to happen until the 1.8 update - so I suspect its a setting that I am struggling to locate. How can I fix this?

Thanks all

Are you using exclusive mode on your audio device? Can you post the audio settings as a screen shot for your windows device.

Here you go! roon-img — ImgBB

No i am not using Exclusive mode. If I turn Exclusive mode on, then the music ‘skips’ many times and sounds like its in fast-forward. The playback stutters and sounds like its in fast forward when ‘exclusive mode’ is turned on.

Thanks for replying to this!

Here is the windows audio settings.

I have turned off all ‘Window Notification sounds’ and it seems to ‘fixed’ this, but its more of a hack than a fix.

Hello @Jeff_Ward,

A) Are you playing to the “System Output” zone in Roon or to the Bluetooth headphones WASAPI device? You should be playing to the WASAPI bluetooth zone in order to avoid system sounds.

B) What do you have selected as your Windows output device in the bottom-right taskbar? If you have the bluetooth headphones as your active audio device and exclusive mode disabled in Roon, I would expect that Windows would forward notifications sounds to the headphones. Try selecting a different audio output for the system output so that the notifications are routed elsewhere.
Try checking to see if you have the bluetooth headphones set as your Windows system output device.

In order to avoid choppy playback on my bluetooth headphones I have to ensure that I’m not connecected to the 2.4 GHz SSID of my network.

-John