Issue with ROCK and USB DAC

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unify system

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Connected with USB from NUC to Mola Mola Makua preamp/DAC.

Description Of Issue

Just bought and installed a NUC7i7BHN with ROCK and want to output from the core directly to a Mola Mola Makua preamp/DAC. The issue is, that when trying to play music the tracks are skipped and not played. This goes both for Tidal and for music stored on connected HD both FLAC and MP3.
When playing to my iPad for test, it works, so issue is only between core and USB DAC.
The Mola Mola supports native playback from linux without need of drivers.
Tried searching the forum but without any luck finding a solution.


Do you have DSP enabled for this device?

Can you share a screenshot of Device Setup for this DAC?

Hi @dylan

No DSP enabled

Your preamp’s DAC doesn’t support the Res you have specified, i.e 768 PCM /DSD512

Try 384 PCM/DSD256.

Problem has been solved - a firmware update of the Mola Mola helped :slight_smile:

1 Like

Unless the firmware increased the Res, you should probably set the Max to what your DAC can handle.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.