Issue with Roon playback on DAP

Core Machine (Operating system/System info/Roon build number)

Intel Nuc

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Virgin Media SH4 1 Gig WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Intel NUC - Sonos AMP

Description Of Issue

Roon works great across all my devices and remotes including MacBook Pro and iPhone 12 Pro. However I have an IBasso DX200 DAP running Android 8.1 which streams Qobuz and other streaming sites with absolutely no problem at all.

I downloaded Roon onto the device and I can access Roon with no issues but when I choose a track to play nothing happens, the screen shows the track as playing (eg pause function is available) but there is nothing playing.

After a few minutes of inactivity I get the following message

‘Qobuz media is loading slowly. This may indicate a networking or connectivity problem’

I closed down Roon and opened up Qobuz and everything plays jus fine. I went back into Roon and decided to play a track from my library and then got the following message.

’ An audio file is loading slowly. This may indicate a performance or hardware problem’

I then closed Roon again and played a track from my library on my DAP which worked perfectly.

Any idea what the issue may be as I was really looking forward to using Roon for playback on my DAP.

Hi @Scott_Hughes ,

Can you please confirm if you have the latest firmware installed on your DAP?

While the Qobuz app can get the track directly from the server, Roon requires processing to happen on the Core first, and then sent out to the endpoint.

Generally speaking, we suggest against using ISP-provided routers, as mentioned in our Networking Best Practices Guide. If you have another router to try with, even temporarily, this can yield some useful results.

Can you please reproduce the issue and let me know the exact local time + date + track you have the issue on? I can try to enable diagnostics for the Roon app on the DAP, perhaps logs can provide further clues.

Hi Noris

The Roon app on the DAP is up to date, the DAP is using Android 8.1. It works perfectly fine on my iPhone 12 Pro.

I have tried a different router and same issue persists.

I have reproduced the issue today at 13.16 UK time listening to the song U.F.Orb by the Orb and again at 13.19 UK time listening to the song Melt by Kelly Lee Owens as shown below.

1 Like

Hello @Scott_Hughes ,

Thanks for sending that screenshot. I’ve just activated diagnostics mode for your account and what this action should do is upload a log set from the Android device next time it’s active. Can you please use the Roon app on the device for at least a few minutes and then let me know here so I can check for the log set? Thanks!

Hi Noris

Ive activated the DAP Android device at 14.20 today, it seems to be working ok at the moment.

1 Like

Hi Norris issue is back again and making Roon unusable on the DAP.

Hi Noris, I am now getting a notification when I start Roon up on the DAP that says

Developer warning for package
Failed to post notification on channel
see log for more details

Hello @Scott_Hughes,

We’ve reached out to iBasso for further assistance with this issue. They are not a official Roon partner so we do not have hardware to test with.


1 Like

Thanks John, hopefully they will send you a DX300 to test on :grin:

Just to add, I had the iBasso DX160 before my Hiby R5 , its WiFi was pretty awful and it could not play back from Roon very well and had same error message. As Roon is sending uncompressed files I think it’s too much for the rubbish WiFi on the dap. Qobuz and Tidal streams worked ok but they are flac and significantly less burden on the WiFi of the device. It might be something else but this was my experience. I sent it back and bought the Hiby R5 which works fine.

Thanks for that, I have no issues streaming or downloading anything else at all and all wifi tests done show great results.

Only issue is when using Roon.

1 Like

I’m having the same issue on the iBasso DX300 DAP. Verified everything is up to date (Firmware, Roon, etc.). I sometimes will get music playing about 10-15 seconds after I press “play”, but then it sort of stutters and only plays for a few seconds and stops. If I adjust the volume through the Roon app playback will typically come back for a few seconds.

I have the latest UBNT WIFI6 access points (regularly in the 700-800Mb/s range per client), running ROCK on a NUC 10 I7 with 16GB of RAM directly connected to my router (UNIFI Dream Machine Pro) via GigE.

Playback via WiFi through other players on the DAP (Tidal/Plexamp/Mango) seems to be fine. Other Roon remotes on iOS/MacOS seem to work fine without issue.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.