Issue with W10 remote Build(923) after prolonged playback on Now Playing screen

Roon Core Machine

NUC8I7BEH, 32GB RAM, Samsung 970 m.2, Samgsung 870 EVO 4TB for library.

Networking Gear & Setup Details

Modem, Asus GT AC5300 router, Netgear 16 port switch, all Ethernet connections except for IOS 12.9 remote.

Connected Audio Devices

Currently using 2 Elac Z3’s, primary sound system not in use during remodel.

Number of Tracks in Library


Description of Issue

First noticed issue after 2 days continuous playback on Build(923) with Now Playing Screen on W10 Laptop Remote.

Back direction arrow took me back past the Home screen to the Genres screen with both directional arrows displayed as seen in the screen shot. Had not accessed that screen at any time since 923 upgrade. Neither arrow or menu worked. Music continued to play but remote screen was stuck.

Restarted remote session on W10 Laptop and the initial screen was still Genres but now the Menu worked to select home screen.

Power cycled laptop and restarted roon remote. The home screen was displayed now with back arrow. Hitting the back arrow returned to Genres screen. Repeated the power cycle and fresh remote session but did not hit the back arrow.

W10 remote is working but seems to get back into this condition after prolonged playback with Now Playing Screen in use.

Have not reinstalled Roon on W10 Laptop or power cycled NUC. Left if alone with the music playing and went back to work on remodel.

Edit Update: Windows 10 remote continues with the strange behavior. Comes up on the Genres page at startup with both directions arrow displayed but neither work. Have to select Home from menu to get it working. Select a playlist from Your Daily Mixes and hitting play does start the music then Roon is stuck on that page with non functioning direction arrows. Navigation is pretty much HOME - MENU, make a selection, then repeat.

Hoping an update appears soon instead of deleting and reinstalling the software. Whats up with that?

OK, got tired of waiting for support, 9 days was long enough.

Thought update to 931 might clear up the problem but no joy there.

Uninstalled then downloaded from the website. That cleared the issue with Roon showing the Genres page on startup with direction arrows that didn’t do anything.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.