Issues recognizing my DAC

Core Machine (Operating system/System info/Roon build number)

Mac OS Big Sur on a 2019 27 inch iMac. Roon build 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Using ethernet connection to the iMac. No impact to the network connection.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Connected via USB to a Sabaj D5 DAC.

Description Of Issue

Roon keeps having issues recognizing my DAC despite being directly plugged into it. All of the other devices on my iMAC including the iMAC sound, Qobuz Native app and Audirvana are able to recognize it and play music no problem. I restarted Roon several times and restarted the iMAC and it did not resolve the problem. I turned off and unplugged the DAC to no avail. This has been occurring for the last few months with Roon and I would be able to fix it with a restart however that is no longer working. Please advise on how to fix.

Hi @Ken_Gaydon,

Welcome to the forum! Your DAC is showing up as attached in the Audio Device page, but not in the Zone picker, that’s strange. I would suggest we try to perform a RAATServer refresh here to see if this helps.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Please let us know is this helps with the issue!

That did not work at all. In addition to my DAC that is directly connected to the iMAC (and every other application is recognizing), Roon will no longer recognize the 2 Roon Endpoints I have configured via Raspberry Pi. Is there any other potential solutions because Roon is pretty much useless for me right now. I love the Roon functionality and the interface when it worked flawlessly for the first 9 months but I can’t renew next month if it continues to be defective like this.

Hi @Ken_Gaydon,

Can you please use these instructions to access your Roon logs and send me a set for review? Thanks!

Please let me know if you are able to access this:

1 Like

Hi @Ken_Gaydon,

Thank you for sending those logs over! It look at the logs but these appear to be as expected, can I please ask that you send me the logs located in your Roon/Logs folder as well (instead of RAATServer)? I would like to review these logs as well for clues, thanks!

Hi @Ken_Gaydon,

Can I please ask you to send the entire Roon/Logs folder to me? There is insufficient information in just the one log file you sent. Thank you.

Can you give me some further direction on it. This is the only log I can find since I reinstalled the software a few weeks ago.

What are the two devices in the grouped zone?

The two devices are my AV Receiver that has Chromecast and Airplay and an Apple TV. Not recognizing my DAC which is plugged directly into the computer via USB or the two Raspberry Pi’s I have which are Roon Endpoints.

Let me know if this might work better. As I mentioned, I tried reinstalling Roon a month ago and unfortunately that didn’t fix the issue. Any help you can provide would be great. I really enjoyed Roon but at this point it is unusable. I don’t plan to renew if we can’t fix and it would be great if I could actually talk to someone about this issue.

Hello @Ken_Gaydon,

Thank you for sending those logs over, I can confirm receipt!

I’m seeing some very strange logs here, can I please ask that you try to perform a reinstall of your Roon app by using the following instructions?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the DAC works without restoring the backup
  • After confirming the fresh install, restore from backup

Please let me know if this helps!

So I followed the steps and it worked right up until I restored the backup and then it reverted back to not seeing the DAC and Roon Endpoint.
I’ll try to reinstall without using a backup. So is it possible to get an extra month on to my current subscription since I have not been able to use the software for at least a month and I’d like to evaluate the new reinstall’s stability before I decide to re-subscribe?

1 Like

Hi @Ken_Gaydon,

Thanks for trying those steps, that is very strange that the backup caused the issue to re-appear, I would try with an older backup or a reinstall without the backup as suggested. I’ll forward your account question to the accounts team via private message.

Thanks for your help. I just went with the complete reinstall. I redid all of my Headphone parametric equalizer settings (which took a while) and did a separate backup of that to always come back to in case I run into the same issue. After the Reinstall, Roon now recognizes my DAC along with all the Roon Endpoints and Sonos players throughout the house.

1 Like

Thanks for letting us know the reinstall resolved the issue here @Ken_Gaydon, please do let us know if you run into any further difficulties and happy listening :headphones: !

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.