Issues streaming from Tidal - Airplay

Hello I am having issues when trying to stream from Tidal within Roon. Currently running Roon core in a Synology DS918+ and streaming to my Onkyo TS NR818 receiver using airplay.
Any song from my library (in the NAS) streams without issue, but when I try to stream anything from Tidal nothing happens, it just skips tacks until I get a message “too many errors. will stop playing”.

I have tried to stream from Tidal directly to my airplay device (apple tv) and this works without issue. So, not sure what could be wrong, but your help would be appreciated.


Hi @Xavier_Pinto,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you play TIDAL content to other zones?

Thanks for your reply.

  • Router - Calix 844G-1
  • Synology DS 918+ (running Roon core) connected to router (via ethernet port)
  • Onkyo TX-NR818 also connected to router (via ethernet port)
  • Apple TV connected to receiver using HDMI
  • Apple TV connected to wireless network

All my library content in the NAS can be streamed thru the receiver. TIDAL cannot thru Roon.
If I stream TIDAL outside of Roon, it works.

Let me know if you need additional information.


Hi @Xavier_Pinto,

If you try to play TIDAL content from Roon to a different endpoint besides the Onkyo, like System Output of a remote, does the same behavior occur?

That’s right. I do not get any sound either when i try to stream Tidal to my iphone (XS Max) or ipad pro.

Hi @Xavier_Pinto,

Thank you for confirming this.

I noticed that the Synology DS 918+ you’re using for your Roon Core falls short of our recommended specs.

Because this device uses a Celeron processor you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.

If you have another device able to function as your Roon Core, my next suggestion would be to try to install and use Roon there. How do things perform when using a Core that meets our recommendations?

Thanks for your reply Dylan. I do not think the Synology is the issue. I have a relatively small library ~ 850 albums. I will try and install the core to an SSD conected to the synology, but I wil have to wait a couple of days for that.

I am inclined to say it is a software issue instead of hardware after reading these posts:

I have tried what seem to work for others (i.e. deleting the cache, but the problem persists).

I have also tried to stream Tidal from my Mac (within Roon of course), and I get the same result: nothing plays, tracks are just skipped.

Hi @Xavier_Pinto,

Thanks for confirming this! Since this happens in Roon regardless of the Core machine, and regardless of what endpoint you’re playing to, it sounds like there are some networking issues at play here.

In the past, we’ve seen this type of behavior improved by using Google DNS. Can you give that a try and let us know if it helps?

Ok. It is working now. Not sure it the DNS change did the trick or what, but this is what I did:

  1. Changed DNS. Tried streaming from core in NAS. Nothing. Tried Streaming form Mac. Nothing.
  2. Uninstalled core from NAS. Installed Core in Mac. Streaming Worked.
  3. Uninstalled core form Mac. Reinstalled core in NAS. Now streaming works.

Anyway. It works now. Let’s see if it stays that way!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.