Issues when switching from MQA to non-MQA track or vice versa

Hi,

This is my first post here.
I’ve been enjoyably trying out Roon and ropieee for a few days now.
I’ve run in to a glitch though and wondering if could get help.

As the topic says, I have issues when switching between MQA and non-MQA tracks.
Intermittently, when either playing and MQA track, followed by, or skipped manually to a non-MQA track and vice versa. I hear a momentary white static noise after which I get no sound at all, or Roon goes crazy and continually switches quickly from one track in the playlist until it reach the last track. Only solution is to reboot ropieee.

My library consists of either flac or DSD, and quite recently MQA (in flac container).
I have my Roon core on a MacBook Pro, my DAC is an M2TECH Young MkIII.
MQA settings on Roon are all default, i.e. MQA Capabilities=Decoder and Renderer, Enable MQA Decoder=Yes.

I have sent logs with identifier c5275bd0406f5eae.
Kindly check.

Thanks,

goldhorse

Tune re-sync delay setting.

Hi Peter,

I tried 50ms to 7000ms but it did not help.
After my post above I connected my MacBook directly to the DAC and even with re-sync delay set at 0ms, any amount of switching between different formats, I could not replicate the issue, so whatever the issue was it seems to be related with ropieee.

Thanks anyway.

Regards,

Daniel

A couple more findings since previous post.

On the RoPieee, when I set the DAC MQA capabilities to renderer only, I could not reproduce the issue. However, I do detect a slight sound difference as compared to full decoding.

On a MoOde, where I installed the Roon bridge app myself, I also could not reproduce the issue, even when re-sync delay is set at 0ms.
The issue with MoOde though is that it does not detect my DAC as native DSD capable, which is the reason why I was trying out RoPieee in the first place.

I thought at first it may be an issue on the DAC side, but then I could not replicate the issue connected to a Mac or another Raspberry Pi distribution. Even while all this is happening, the RoPieee is responsive to ssh and terminal commands, the web is also responsive, so it seems to me that only the Roon Bridge in the RoPieee is somehow frozen.

Any further thoughts appreciated.

TIA

goldhorse

EDIT: The issue happened in the moOde as well. Just needed a few more tries. So might be an issue with the bridge for Linux?

Let me have a look at the logs (the feedback also collects the logs from RoonBridge).

Hi Harry,

Thanks for checking.
I have sent another feedback your way.
It seems this is not just happening between MQA and non-MQA tracks.
I just experienced it when a 44.1/16 track finished and moved on to another 44.1/16 track.

eee4e03c61261de0

This is on a brand new RPi 3B+ with a freshly imaged SD card.
(The previous one on an RPi 3B)

Regards,

Daniel

There’s nothing wrong in the logs, also not for the RoonBridge (afaict).
I think it’s time to call in @support, because this could be device (the Young Mk III) related.

I have shifted the thread to the Support forum so it can receive proper attention by the Roon support team.

@spockfish has already flagged them down, so stay tuned for follow-up!

Hi Harry,

Appreciate your time looking into this.
After some more poking around, it does seem that the there is nothing wrong from roon to ALSA.

  1. roonbridge service is up and running
  2. cat /proc/asound/card1/pcm0p/sub0/hw_params shows that the stream is open, so this leaves the DAC itself.
  3. Unplugging and replugging the USB cable seems to do the trick.

So from above it does seem to be a USB sync issue between the RasPi and the DAC.
I’ve tried different settings of the Resync Delay all up to 7000ms, but in conclusion the issue will still happen, it’s just a matter of how far in between. The Resync Delay is I think designed to prevent the issue, not solve it when it does happen.

I’ll guess I’ll have to try it out with the DAC manufacturer, although judging from their documentation, they’re not that hot with support for Linux based environments.

Thanks anyway for your support.

Regards,

Daniel

Hello @goldhorse,

Just wanted to check in with you here, are you still experiencing this issue? Some other suggestions that may not have been said yet:

  • You might want to try replacing that USB cable in case it is faulty
  • You may want to try reinstalling the driver for your DAC

I have also gone ahead and enabled diagnostics mode on your account and what that will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. To help us better diagnose this issue, I kindly ask for you to replicate the problem and let me know the exact local time in your country that the issue occurs at so that we can cross-reference the diagnostic data and see if there is anything unexpected going on with Roon at that time. Please let me know when possible.

Thanks,
Noris

1 Like

Hi Noris,

Repeated the issue three times tonight July 9th, between 10:20 PM and 10:25 PM JST.

USB cable being faulty is highly doubtful: the issues only happens in between tracks.
There are no manufacturer provided drivers for Linux based OS.

Thanks,

Daniel

Hello @goldhorse,

Thank you for providing those timestamps, I have gone ahead and created a case for you with our QA team. I will be sure to let you know once QA has completed their analysis of your logs and passes their report back to me, I appreciate your patience while this occurs on our end. Please leave Roon running on your Core so that any additional diagnostics needed will be able to reach our servers successfully.

Thanks,
Noirs

Just to bring closure to this thread.
The issue has not been resolved with this DAC.
Since my last post I’ve auditioned a Chord Qutest and while this does not have an MQA decoder/renderer I have not been able to reproduce the issue in a week since I’ve been using it. I’ve tried my best to “abuse” it by switching between DSD, FLAC, ALAC, WAV formats and it hasn’t missed a beat, and it sounds great too. So I think I’ll be going with the Qutest instead.

Many thanks all to those who’ve offered to help.

Regards

Daniel

Hi @goldhorse,

My Roon system: ASUS GL552JX(Core) with Win 10 Pro + AO; Pi 3B + Ropieee(Bridge); M2TECH Young MkIII DAC. I have NO problem, and the sound is great.
Your system work well with Qutest, so the issue is probably your DAC, just for your information.

Happy Listening.