Issues with ASIO4ALL and Roon Remote

Roon Core Machine

Win10 v21h1, i7 930, 16GB RAM

Networking Gear & Setup Details

Google Wifi Router / Trendnet gigabit switch

Connected Audio Devices

Schiit Bifrost 2 connected via USB on Win10 PC that is running Roon remote

Number of Tracks in Library

46,191 tracks

Description of Issue

When using ASIO4ALL v2.15 (I didn’t try on earlier versions), if I close Roon remote and re-open, the only playback devices are network streamers, not even standard USB with WASAPI.

Logging out and back into Windows (not reboot) allows it to play correctly again until closed and re-opened once more.

Hi Mark, welcome! Quick question: why are you using ASIO4ALL and not WASAPI? The former is basically a wrapper on top of the latter. Roon can work with WASAPI just fine.

Hi Marian,

After testing, ASIO4ALL sounds quite a bit more forward, so subjectively I decided I prefer the sound.

Did you enable “Exclusive mode” when you tried WASAPI? That would allow Roon to send data directly to the device and bypass the OS mixer.

Yes, exclusive mode was enabled while A/B testing.

In that case, I don’t see how ASIO4ALL could have made any difference, as it is just another layer on top, adding complexity and potential failure points.

There’s certainly a noticeable increase in at least volume, which doesn’t necessarily mean better SQ. I’ll stick with WASAPI and just crank up the amp a bit more.

Yes, everything else being equal, louder is always perceived as better in A/B tests. I’m sure you did your due diligence, but I would go with a fixed volume in Roon and using the preamp’s volume button.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.