Issues with Tidal (only in Roon) the last ~6 months

Core Machine (Operating system/System info/Roon build number)

Intel i7 7700k, 32GB RAM, Windows 10 x64
Roon 1.7 (build 667) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All devices on ethernet, HPE switches, OPNsense router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Main stereo system: InnuOS Zen Mk3 USB to Arcam D33 DAC
Office system: USB from core device to Schiit Jotumheim Multibit device

Description Of Issue

Tidal simply hangs for 20-30s when trying to start a song and/or when trying to “open” an album from search. This happens sporadically.
Last night it happened for almost every song, even on the same album.
This is not happening to local songs or in the Tidal client on a pc or iOS.
It’s not the first time I’ve had this, but it’s been happening many more times than usual since about 6 months back.
Also, the Roon GUI and app has been getting slower and slower with the latest releases.

1 Like

Hello @Andreas_Lindmark, does this issue still occur if you connect the core directly to the router? Also, have you tried changing to google or cloudflare DNS?

No, That’s not possible, I’m using pi-hole and an internal DNS cache.

I think I “solved” it however by logging out of TIDAL and logging in again.
TIDAL does something weird with logged in sessions after some time it seems.
It’s fine now, both on my PC and on InnuOS

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.