Issues with Volume Control [fixed]

I’m seeing something funny with the volume control. I am using Dirac as my output device, in exclusive mode, I have volume leveling set, in Radio mode. When Roon skips to the next song, the value is quite loud. If I click on the volume control in the playback window, even at the same level, the volume drops back down to an appropriate level.

Looking at the playback chain, it indicates that the volume is being adjusted, but it sounds like the level adjustment is not being applied until I click on the volume control.



Thanks for the report @Carl_Kesselman – can you let me know a little more about your setup, as described here? We’ll take a look once we know a bit more about your configuration, output device, and media, ok?



Here is the info:

Roon 1.1 Release 88 (although had the problem with the previous version as well).
Windows 10
Custom HTPC built by yours truly. Intel processor, Dirac Live, Lynx E44. Issue is on a digital AES output going to Lavry DA10.

All music is stored on local hard drive. I also have a tidal account. I believe the problems are on local music.

I am getting a hang on analysis of one file (I cannot figure out where to find the logs to figure out what file).

I should probably do a bit more debugging to see if I can narrow the options down.



A little more information. Seems to only happen when set to exclusive mode. However, the behavior is a bit more peculiar. I play a track,and adjust the volume level down so something less then 100, say 50. Now I drag the current play position forward to another position in the track. The volume shoots back up to what sounds like 100, even though the volume control says 50. Then if I adjust the volume control back to 50 (by just moving it up to 51 and then back to 50), it goes back to the correct volume.

It looks like this doesn’t have anything to do with volume leveling.


Hey @Carl_Kesselman – one thing to keep in mind is that Roon has no software volume control. All we do is send volume control commands to your selected output.

Any chance you’re running with any volume control settings in Dirac that might be changing the setting back when you seek in the track?

RIght. I know that there is no software volume control, and that this is done via the WASAPI. Further compounding the complexity, I’m looking at the device volume in windows audio panel and it doesn’t change when I seek from Roon. So the most dramatic demonstration is I set the volume at 0 from Roon. The windows audio panel for the Dirac device says that its volume is zero, I seek from Roon, and the music is blasting. I tweak the volume to one, and it goes back down to the correct volume.

There are no volume settings that I know of in Dirac.


Ok, thanks @Carl_Kesselman.

@vova and I are going to try and reproduce with Dirac, and we’ll get back to you as soon as possible. With the holiday coming up, it may take slightly longer than normal, so thanks in advance for your patience.


Wondering if you were able to reproduce this problem. It still exists with the latest version.




Still a problem in 102…


Hi @Carl_Kesselman – sorry for the slow response here. I discussed this with the team today, as our QA guys have spent hours with Dirac trying to reproduce, both when you initially reported this and this week, to no avail.

I’d like to try to debug this a little further, so we can figure out how your setup differs from what we’re testing with.

I assume this all still accurate (other than the Roon version number)?

Can you try taking Dirac out of the chain and see if it makes any difference in this behavior? Also, any additional details about your settings in Roon, Dirac, or anywhere else along the chain might help us reproduce what you’re describing.

Appreciate your patience here @Carl_Kesselman – we’ll figure this out!


Thanks for getting back to me. I think I’ve got this figured out. It looks like what I’m seeing is an interaction between Roon, Dirac the topology driver in the E44 driver. If I switch Dirac to another one of the playback channels in the E44 (there are 4 stereo pairs supported by the card) and then route them to the exact same output, it works as expected. I’m not exactly sure why the driver treating 1/2 different the 7/8, but it seem to. So the good news, is that this seems to be Lynx’s problem and not yours.

Thanks for your help.


1 Like

Thanks for letting me know Carl, and sorry this dragged on so long :frowning:

@vova and company spent a lot of time on this, so I’m glad we figured out what’s going on here!