Itunes library import stops at 6666 tracks

Hi there!

I am new to Roon. Starting by importing iTunes library, however it stops after 6666 tracks imported. I have a pretty large iTunes library of over 80k tracks. I tried to disable and re-enable the iTunes library watching. From the screen shoot you can see that the Roon software is able to see there are many more tracks but it still stops at 6666 tracks after scanning 80k of tracks. Very confusing. All my albums in Roon are missing tracks… Please help! Thanks!


Where is your iTunes Library stored??

Is it on the local drive …or more likely on a NAS due to the size of the Library??

The library itself(the .xml file) is in local drive. But the tracks files are in a NAS.

I was trying to add a new album into iTunes and then restart Roon. It now seems to adding the remaining tracks. Strange…

Try following the instructions I posted in this link which sorted out another member with similar issues connecting to a NAS via Roon

Macs still try to use the flaky AFP Protocol to connect to NAS with Time Machine functionality…and it’s better to use the more robust SMB protocol that Macs use to connect to other Macs

Suggest that you Unmount the NAS using your Finder app…then in Finder, click Go on Menubar…Connect to Server…enter smb:// [IP address for your NAS]

Then back to Roon…and now point at your Music folder on your NAS

First of all, problem solved. The real problem is the library itself. Because of remote volume did not get mounted properly the iTunes magically changed the base of library to local path so most of the file is broken link, no wonder why Roon was not able to find them.

But I still need to report a possible bug. During my fight against broken library, I was covering the iTunes library with another library from another machine with mostly similar but different tracks. Roon keeps crashing after scanning after 30k tracks. At that time Roon has around 7k tracks already. I guess it is because the link of existing Roon tracks conflict with the new library file? Later I completely uninstall Roon(remove ~/Library/Roon, Saved State, …) and reinstall everything goes smoothly.