Jitter when switching songs at the same Sample Rate [Artifacts]

I am on lifetime subscription and just back to Roon after the iPad remote is launched.

One thing that troubles me a LOT is that there is jitter whenever switching songs at the same Sample Rate (no matter at 44.1, 48, 88.2, 96, 176.4, and 192)

I am currently using Solution 590 from my mac mini as USB audio out to my processor.

I tried using the MAX Sample Rate (set to Up to 96kHz). But that did not solve the issue.

However, when switching songs between different sample rate, there is NO jitter…
But that surely does not make sense to me to switch albums when listening right? esp I want to finish a particular album which, obviously, is at the same sample rate…

Any idea?

ah, for comparison, when I use Audirvana Plus, it behaves perfectly without any jitter when switching songs at the same sample rate…

Just so that we are all on the same page:

  • when you refer to switching songs, do you mean pausing one song mid
    playback and then selecting and playing another song, or are you
    referring to continuous playback ?

  • when you refer to jitter, what is it that you are hearing ? A skip or click in playback or a change in sound quality ?

switching songs means:
while playing Song A, clicking the “Next” button which is next to “Play/Pause” (meaning doing this in the same album) &
while playing Song A, Clicking another album which is of the same sample rate, then click “Play Album” or simple click the name of the track.

I was hearing “didididididididididi”

Very strange and I can see why it would be troubling !

Does this behaviour persist after power cycling your mac mini and the Solution 590 ?

I can’t recall hearing of a similar issue, so I will leave you in the good hands of @mike or @danny , who will see your post on their usual rounds of the Support forum. Best wishes for a speedy fix.

Edit: flagging for @kevin or @vova also, as mike is on a well deserved break

Ok. We have a Solution 590 in-house. I will try to reproduce the problem here.

hello any updates?

Lets notify @brian and see if he could reproduce this behaviour.

Hey @B_Sherhee_Tsang – thanks for your patience here.

Can you let me know what OS you’re running? We tried on Yosemite, but we weren’t able to reproduce this.

Also, can you post a screenshot of your Output settings for the Solution 590, as described here?